makuxina
12.08.2020 00:49

Разобрать программу, написать программу и
расчет

фрагмент действий

а:= -3;
b:=(a+7)-а;
b:=b-а;
c=(-b*a)-(a*a);

вывести все переменные​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ivan89052
27.05.2022 19:47
Рекомендуется использовать формулу мальтуса, изменения числа рыб  n= k*n-q*n*n если за начальное количество рыб принять n0,то через год рыб в пруду будет n1=n0+k*n0-q*n0*n0,через два года n2=n1+k*n1-q*n1*n1 в таблице excel в ячейку a1 введите значение к=1,в ячейку b1 значение q=0,01,в ячейку с1 значение n0=100, в ячейку в2 формулу =c1+a1*c1-b1*c1*c1 (это количество рыб за 1 год) , в ячейку в3 формулу =b2+$a$1*b2-$b$1*b2*b2(количество рыб за 2 год) , скопируйте формулу с ячейки в3 до ячейки в11. изменяйте значение ячейки а1, например, поставьте значение 1,908, и получите 2000 рыб через 10 лет.
0,0(0 оценок)
Ответ:
Lena121618
14.05.2021 23:16

Привет!


Периметр:


program x;

var

y,x1,x2,x3,x4,x5,x6,x7,x8,x9,x10,x11,x12,x13,x14,x15,x16:integer;

begin

writeln('Введите длины всех сторон шестнадцатиугольника, см: ');

readln(x1,x2,x3,x4,x5,x6,x7,x8,x9,x10,x11,x12,x13,x14,x15,x16);

y:=x1+x2+x3+x4+x5+x6+x7+x8+x9+x10+x11+x12+x13+x14+x15+x16;

writeln('Периметр данного шестнадцатиугольника,см= ',y);

readln;

end.


Площадь:

var a : integer;  

S : real;  

function SquareTr(a : integer) : real;  

begin  

SquareTr := (sqrt(3)*a)/2  

end;  

BEGIN  

writeln('Введите сторону шестнадцатиугольника: ');  

ReadLn(a);  

S := 16 * SquareTr(a);  

Writeln('Площадь шестнадцатиугольника со стороной а, равна ', S:16:16);  

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота