arinadamnyanova
05.05.2021 04:58

Составить программу по информатике: вычислить объём вещества массой 0, 45 кг при изменении плотности от 0, 5 до 1 кг/м3 с шагом 0, 1 кг/м3

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
яqwertyuiop123
15.05.2021 23:09
Сначала надо избавиться от ошибок (пункт №3)
иначе не сможем выполнить 1 и 2 пункт задания.
  Исправляем if N mod 10 k:=N mod 10; на if (N mod 10 < k) then k:=N mod 10;
  Исправляем N:N div 10; на N:= N div 10;
 
После исправления ошибок при вводе 537 получим 3
Программа будет работать правильно для любого числа,
у которого вторая цифра слева меньше первой цифры, например:
7193

Чтобы программа работала правильно для всех чисел надо
изменить это: while N > 10 do на while N > 0 do

После всех исправлений код программы стал таким:
var
  N, k: integer;
begin
  readln(N);
  k := 9;
  while N > 10 do
  begin
    if (N mod 10 < k) then k := N mod 10;
    N := N div 10;
  end;
  write(k)
end.
0,0(0 оценок)
Ответ:
Iikhovaydov
02.12.2021 05:40

ответ:Многие страны перешли на т.н. «информационное общество», некоторые – в процессе перехода, в зависимости от факторов, влияющих на то или иное население. Все меньше уделяется внимания  печатным изданиям: ученные говорят о том, что лет через 30 газеты, журналы, книги исчезнут с прилавков.

С одной стороны, электронные страницы – это хорошо, меньше вреда наносится окружающей среде, да и хранить большое количество информации легче и удобнее в электронном виде. С другой стороны – человечество становится все более зависимым от техники.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота