361212
26.06.2022 19:11

Напишите программу )) дан массив действительных чисел.среди них есть равные .найти первый максимальный элемент массива и заменить его нулём

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Aksa2101
24.05.2020 06:53

Program num1;
Uses crt;
Var x:array[1..10] of real;
max:real;
i : integer;
Begin
clrscr;
for i:=1 to 10 do
begin
write('x[',i,']=');readln(x[i])
end;
max:=x[1];
for i:=1 to 10 do
if x[i]>=max then max:=x[i];
Writeln('Max=',max:3:1);
for i:=1 to 10 do
if x[i]=max then begin x[i]:=0;break end;
for i:=1 to 10 do write(' *',x[i]:3:1,'* ');
End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота