skybeast
21.06.2021 01:06

Напишите программу, которая вычисляет произведение всех чисел, оканчивающихся на 2, из диапазона от 0 до 50.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Savich111
14.09.2020 07:23

using namespace

Объяснение:

using namespace std;

int main()

{

 int a,sum=2;

  for (a = 1;a <= 50;a++){

      if(a%10==2){

          sum = sum * a;

      }      

  }

  cout <<sum / 2;

}

0,0(0 оценок)
Ответ:
Alecsa20033
14.09.2020 07:23

using System;

using System.Linq;

class NewClass

{

   

   static void Main()

   {

       int[] array = Enumerable.Range(0, 51).ToArray();//диапазон - [0; 50]!

       foreach(var i in array)

           System.Console.Write($"{i} ");

       System.Console.WriteLine();

       System.Console.WriteLine(array.Where(var => var % 10 == 2).Aggregate((var1, var2) => var1 * var2));

   }

}

Объяснение:

Диапазон от 0 до 50 включительно. Если диапазон нужен такой, чтобы 50 не включалось, измените 51 в методе Range() на 50.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота