daramalahova907
30.07.2021 00:08

Написать программу на языке программирования Паскаль, используя операторы ветвления if, then, else. Ведется прием на работу на конкурсной основе. Условия приема требуют 20 лет трудового стажа и возраста не более 45 лет.Определить,будет ли человек принят на работу. Примечание: два условия записываются в виде (x<5) or (x>6), (x<5) and (x>6) - выберите нужную запись для условия, подставляя значения из задачи.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
xabibullinaeliza
02.11.2020 04:58

#include <iostream>

#include <vector>

#include <algorithm>

using namespace std;

int main()

{

int s, n;

cin >> s >> n;

vector <int> a(n);

for(int i = 0; i < n; i++)

 cin >> a[i];

sort(a.begin(), a.end());

int prev_s = 0, count = 0;

for(int i = 0; i < n; i++)

 if(a[i] >= s)

 {

  prev_s = a[i];

  count++;

  for(int j = i; j < n; j++)

   if(a[j] - prev_s >= 3)

   {

    count++;

    prev_s = a[j];

   }

  break;

 }

cout << count;

return 0;

}

0,0(0 оценок)
Ответ:
kutina1969
29.12.2020 06:23

#include <algorithm>

#include <iostream>

#include <random>

#include <vector>

 

void fillVector(std::vector<int>&, int lowerBound, int upperBound);

void print(const std::vector<int>&);

 

int main() {

 

   std::vector<int> vec { };

   std::size_t size { 0 };

 

   std::cout

       << "Please, enter the number of elements: ";

   std::cin

       >> size;

 

   if (size < 1 || size > 1000) {

 

       std::cerr

           << "The size must be in the range [1; 1000]" << std::endl;

 

       return 1;

 

   }

 

   vec.resize(size);

 

   fillVector(vec, 0, 100);

   print(vec);

 

   std::size_t changes { 0 };

 

   for (std::size_t i { 0 }; i < vec.size() - 1; ++i) {

 

       int tempValue { 0 };

 

       for (std::size_t j { i + 1 }; j < vec.size(); ++j) {

 

           if (vec.at(i) > vec.at(j)) {

 

               tempValue = vec.at(i);

               vec.at(i) = vec.at(j);

               vec.at(j) = tempValue;

 

               ++changes;

 

           }

 

       }

 

   }

 

   print(vec);

 

   std::cout

       << "Number of changes: " << changes << std::endl;

 

   return 0;

 

}

 

void fillVector(std::vector<int>& vec, int lowerBound, int upperBound) {

 

   std::random_device rd;

   std::mt19937 gen(rd());

   std::uniform_int_distribution<int> dist(lowerBound, upperBound);

 

   int randomValue { };

 

   for (auto& value : vec) {

 

       while (true) {

 

           randomValue = dist(gen);

       

           if ( std::find( vec.begin(), vec.end(), randomValue) == vec.end() ){

       

               value = randomValue;

               break;

       

           }

 

       }

 

   }

 

}

 

void print(const std::vector<int>& vec) {

 

   for (const auto value : vec) {

 

       std::cout

           << value << " ";

 

   }

 

   std::cout

       << std::endl;

 

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота