imranio
02.10.2021 17:33

Составить программу которая вычисляет произведение всех трехзначных чисел которые кратны 5
Желательно на паскале

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
schkuleva1980
16.06.2020 22:25

Маловато инфы...попробуйте объяснить конкретнее

" «Ваше имя начинается с A или B», если первая буква $name переменной - «A» или «B» "

$name = ИМЯ;

if ($name == $name) {  //всегда проверка

$string = $name;  //для сравнения

$a = $name{0}; //получаем 1-вую букву имени (строки)

if ($a ==  "A" or $a == "B") { // проверяет равно ли имя на эту букву

echo "Ваше имя начинается с A или B"; // если равно, то выводит

} elseif ($a == "C") {

echo "Ваше имя начинается с C";

} else {

echo "Я не знаю этого письма";

}

}

P.S очень костыльно (ибо вопрос не понятен) + это только пример

"Мы предполагаем, что все имена начинаются с заглавной буквы" это задание от уо? можно же использовать mb_strtolower ( if (mb_strtolower($name) == "АЛЕНА") // всегда будет = алена)

0,0(0 оценок)
Ответ:
игорь800
02.09.2020 20:16
Var
  count, i, d1, d2, d3, d4, d5, d6: integer;
const
  MIN = 189980;
  MAX = 205505;
begin
  count := 0;
  for i := MIN to MAX do
    begin
      d1 := i div 100000;
      d2 := i mod 100000 div 10000;
      d3 := i mod 10000 div 1000;
      d4 := i mod 1000 div 100;
      d5 := i mod 100 div 10;
      d6 := i mod 10;
      if ( (d6 * 100000) + (d5 * 10000) + (d4 * 1000) + (d3 * 100) + (d2 * 10) + d1 ) = i 
      then
        count := count + 1;
    end;
  writeln('в промежутке от ', MIN, ' до ', MAX, ' ', count, ' счастливых билетов');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота