rassvet1123
16.04.2023 09:36

1.Написать программу для вычисления выражения у=: X/4+x*x*x2.

2.Coставить программу сортировки по возрастанию значений трех переменных, А,В,С

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kamilaiks466
20.10.2021 05:33

В данном случае я добавил цикл while (true). Как только пользователь введет число 2 - произойдет выход из цикла и соответственно завершение программы.

Объяснение:

#include <iostream>

#include <Windows.h>

using namespace std;

int main()

{

SetConsoleCP(1251);

SetConsoleOutputCP(1251);

cout << "Программа определения простого числа" << "\n";

cout << "" << "\n";

int n, s = 0, i = 2, j = 0, menu = 1;

while (true) {

 cout << "Введите натуральное число:  >"; cin >> n;

 if (n == 1)

 {

  cout << "Число не простое и не составное!" << "\n";

 }

 else

 {

  while (i <= sqrt(n))

  {

   if ((n % i) == 0) s++;

   i++;

   j++;

  }

  if (s == 0)

   cout << "Число простое!" << "\n";

  else

   cout << "Число составное!" << "\n";

 }

 cout << "Кол-во итераций = " << j << "\n" << endl;

 cout << "Желаете продолжить? (2 - выход): ";

 cin >> menu;

 if (menu == 2) {

  break;

 }

}

system("PAUSE");

return 0;

}

0,0(0 оценок)
Ответ:
alinaalin2208
24.12.2022 07:13

#include <iostream>


#include <cstdlib>


#include <ctime>


using namespace std;


int main()


{


int m[15] = {};


double t = 0;


srand(time(NULL));  // генерация нового числа всегда разная, т.к берётся разное время

for (int i = 0; i < 15; i++)


{


 m[i] = rand();


 cout << "[" << i+1 << "] " << m[i] << endl;


 t = t + m[i];


}


cout << endl << t << "/15 = " << t / 15 << endl;


}

Проверка:

прикреплённое фото

11737 + 5520 + 24807 + 25121 + 13476 + 31412 + 28456 + 32654 + 8 + 14540 + 12889 + 8915 + 8179 + 19225 + 30596 = 267535


С++ составить массив из 15 рандомных элементов и вывести среднее арифметияеское этих чисел в с++
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота