magamusaev201
11.04.2023 08:56

Методика выполнения работы 1. программа имеет линейную структуру в соответствии с алгоритмом на рис. 5.2. s1 – блок ввода исходных данёных a, b, c. s2 – блоки расчета полупериметра треугольника p и площади s. s3 – блок вывода результата: площадь s. введите программу решения этой (см. пп. 1-3, лабораторная работа № 1). program geron; uses crt; var a,b,c,p,s: real; begin clrscr; {ввод исходных данных} writeln(‘введите значения сторон треугольника a,b,c’); readln(a,b,c); {расчет полупериметра и площади треугольника} p: = 0.5*(a+b+c); s: =sqrt(p*(p-a)*(p-b)*(p-c)); {вывод результата расчета} writeln(‘площадь треугольника = ’, s: 5: 3) end. 2. откомпилируйте программу и исправьте возможные ошибки. затем запустите программу на счет (см. пп. 4-5, лабораторная работа № 1). 3. проведите тестовый расчет, чтобы убедиться в правильности работы программы. введите значения сторон: a=1, b=1, c=1. должен получиться результат s=0.433. 4. проведите серию расчетов для различных значений сторон треугольника. 5. если значения сторон являются константами (например, все равны 1), то в данную программу можно ввести следующие изменения:  перед разделом var надо добавить раздел констант – const a=1; b=1; c=1;  из раздела var убрать a,b,c – var p,s: real;  убрать ввод исходных данных – удалить операторы writeln(‘введите…’); readln(a,b,c); 6. сделайте указанные исправления и повторите пп. 1-3 данной работы. для самостоятельной работы составить программу на языке паскаль для нахождения значения выражения. константы a, b, c вводятся с клавиатуры. сложные аргументы функций вычислять отдельно, tan(x) вычислять как sin(x)/cos(x), ctan(x) → cos(x)/sin(x), xy → exp(y*ln(

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nikitabarkov1
13.01.2021 01:27
Каждый символ в кои-8 имеет объем информации 1 байт. всего текста 60*30 = 1800 байт на каждой странице. растровое изображение передает не более 8 = 2^3 цветов, значит, на кодировку цвета используется 3 бита. размер каждого рисунка 120*240*3 = 86400 бит = 10800 байт. а рисунков 2 на каждой странице. таким образом, каждая страница содержит 2*10800 + 1800 = 23400 байт. модем со скоростью передачи 28800 бит в сек передал документ за 5 сек. значит, он передал 28800*5 = 144000 бит = 18000 байт. но это меньше, чем находится на одной странице. вывод: у вас ошибка в условии.
0,0(0 оценок)
Ответ:
Shadow69moon
04.06.2023 10:58
Const   n = 50; // количество чиселvar   k: array [1..n] of integer;   i, j, n1, n2, minr, a, b: integer; begin   writeln(n, ' ', ': d');   a : = random(1000);   b : = random(1000);   minr : = 10000;   for i : = 1 to n do       k[i] : = a + random(b);   for i : = 1 to n do       for j : = 1 to n do           if ((abs(k[i] - k[j])) < minr) and (k[i] < > k[j]) then           begin               minr : = abs(k[i] - k[j]);               n1 : = i;               n2 : = j;           end;   writeln(n1, ' ', n2); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота