revazhora
28.08.2021 16:58

Информатика.10 класс задачи на циклы. ПАСКАЛЬ

1. Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в последовательности N, а затем сами числа. Программа должна вывести одно число — сумму чисел, кратных 3. Пример работы программы:
Входные данные: 3, 12, 25, 9
Выходные данные: 21.

2. Напишите программу, которая позволяет вычислить все значения функции y=2х +4 для ) 5;2( x с шагом 0,5. Программа должна вывести таблицу значений x,y.

3. Напишите программу, которая в последовательности натуральных чисел определяет количество всех чётных чисел, кратных 9. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0. Программа должна вывести одно число: количество всех чётных чисел, кратных 9.
Входные данные: 27,24,18,22,36,0
Выходные данные:2

4.Напишите программу, которая определяет количество нечетных цифр в числе N. Программа получает на вход число N (N описывается типом longint). Программа должна вывести одно число – количество нечетных цифр числа. Пример работы программы:
Входные данные: 12564
Выходные данные: 2

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Neznayka56000
12.02.2023 05:38

Program Begenjov1997;

const

 n = 30; {Количество элементов массива}

 m = 10000; {Максимально возможное значение элемента}

var

 a:array[1..n] of integer;

 i, sum: integer;

 s:string;

begin

 s:=' -=Alphaeus=- ';

 for i:=1 to 22 do begin write(s[i]); sleep(60) end;

{заполняем массив случайными числами}

 writeln; randomize;

 for i:=1 to n do a[i]:=random(m+1);

{Ищем максимальный и минимальный элементы}

 sum:=0;

 for i:=1 to n do

   if (a[i]<200) and (a[i] mod 5 = 0) then sum:=sum+a[i];

{Заменяем эти элементы найденной суммой}

 for i:=1 to n do

   if (a[i]<200) and (a[i] mod 5 = 0) then a[i]:=sum;

{Вывод}

 writeln;

 for i:=1 to n do writeln(a[i]);

end.

0,0(0 оценок)
Ответ:
madina123452
12.02.2023 05:38

Program Begenjov1997;

const

 n = 30; {Количество элементов массива}

 m = 10000; {Максимально возможное значение элемента}

var

 a:array[1..n] of integer;

 i, min, max: integer;

 s:string;

begin

 s:=' -=Alphaeus=- ';

 for i:=1 to 22 do begin write(s[i]); sleep(60) end;

{заполняем массив случайными числами}

 writeln; randomize;

 for i:=1 to n do a[i]:=random(m+1);

{Ищем максимальный и минимальный элементы}

 min:=a[1]; max:=a[1];

 for i:=1 to n do

   begin

     if (a[i]>max) then max:=a[i];

     if (a[i]<min) then min:=a[i];

   end;

{Заменяем минимальные элементы на максимальные}

 for i:=1 to n do

   if (a[i] = min) then a[i]:=max;

{Вывод}

 writeln('Массив:');

 for i:=1 to n do writeln(a[i]);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота