WakaAmigo
09.07.2022 22:08

Задание 1. Программирование алгоритмов линейной структуры. Нарисовать блок схему и написать программу вычисления функций.
Арифметическое выражение =√2+−2sin3(+)/ =cos23−/√2+2
Значение исходных данных a=1.5 b=15.5 x=-2.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
мариана24
12.11.2021 11:43
Var a,b,c: real;
Begin
write('Введите 3 числа: ');
readln (a,b,c);
if c = sqrt(a*a + b*b) then writeln('Число ',c,' является гипотенузой прямоугольного треугольника со сторонами ',a,' ',b,' ',c)
else if a = sqrt(c*c + b*b) then writeln('Число ',a,' является гипотенузой прямоугольного треугольника со сторонами ',a,' ',b,' ',c)
else if b = sqrt(a*a + c*c) then writeln('Число ',b,' является гипотенузой прямоугольного треугольника со сторонами ',a,' ',b,' ',c)
else writeln('Эти числа не являются сторонами прямоугольного треугольника')
End.
0,0(0 оценок)
Ответ:
Лёха142002
29.01.2023 11:25
1)
var a,b,s:integer;
begin
Readln(a,b);
s:=0;
if (a<0)and(b<0) then
 begin a:=-a; b:=-b; end;
if a<0 then for var i:=1 to b do s+=a
else for var i:=1 to a do s+=b;
WriteLn(s);
end.

Пример:
-7 15
-105

2)
var n,s:integer;
begin
Readln(n);
s:=0;
for var i:=1 to n do s+=i;
WriteLn(s);
end.

Пример:
100
5050

3)
var a,b,s:integer;
begin
Readln(a,b);
s:=0;
for var i:=a to b do s:=s+i*i;
writeLn(s);
end.

Пример:
2 5
54

4)
var a,b,n:integer;
begin
Readln(a,b,n);
for var i:=1 to n do write(random(b-a+1)+a,' ');
end.

Пример:
10 20 5
11 12 14 14 18
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота