daryachita
10.04.2020 22:11

Программе используется одномерный целочисленный массив A с индексами от 1 до 10. Значения элементов равны 4; 2; 5; 6; 7; 7; 7; 5; 5; 9 соответственно, т.е. A[1] = 4; A[1] = 2 и т.д.
Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на языке программирования Паскаль.
c:= 0;
for i := 1 to 9 do
if A[i - 1]>= A[i] then
begin
t:= A[i];
A[i]:= A[i - 1];
A[i - 1]:= t;
c:= c + 1;
end;
С решением

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
LunnayaLiliya
11.05.2022 18:31

1)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
 
int main()
{
    char s[20];

    cout << "What is your name: ";
    cin >> s;

    cout << "Hello, " << s << endl;
 
   return 0;
}

 

2)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strlen;
 
int main()
{
    char s[100];

    cout << "Enter the string: ";
    cin.getline(s, 100);

    for(int i = strlen(s) - 1; i >= 0; i--)
    {
        cout << s[i];
    }
    cout << endl;
 
   return 0;
}

 

3)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strlen;
 
int main()
{
    char s[20];
    bool x = true;

    cout << "Enter the word: ";
    cin.getline(s, 100);

    for(int i = 0, j = strlen(s) - 1; i <= j; i++, j--)
    {
        if(s[i] != s[j])
        {
            x = false;

            break;
        }
    }

    if(x)
    {
        cout << "Palindrome" << endl;
    }
    else
        cout << "Not palindrome" << endl;
 
   return 0;
}

 

4)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strlen;
 
int main()
{
    char s[100];
    char n;

    cout << "Enter the string: ";
    cin.getline(s, 100);

    for(int i = 0; i < strlen(s); i++)
    {
        if(s[i] == 'a')
        {
            n = 'a';

            break;
        }
        else if(s[i] == 'o')
        {
            n = 'o';

            break;
        }
    }

    if(n == 'a')
    {
        cout << "\nThe first letter of A" << endl;
    }
    else if(n == 'o')
    {
        cout << "\nThe first letter of O" << endl;
    }
    else
        cout << "These letters are not available" << endl;
 
   return 0;
}


1)написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)написать программу
0,0(0 оценок)
Ответ:
vanzoca
21.10.2021 07:52

Решение. Обозначим высказывательную форму "юноша по имени А носит фамилию Б" как АБ, где буквы А и Б соответствуют начальным буквам имени и фамилии.

Зафиксируем высказывания каждого из друзей:

ДМ   и   БХ; АМ   и   ВБ; ВТ   и   БМ; ВБ   и   ГЧ; ГЧ   и   АТ.

Допустим сначала, что истинно ДМ. Но, если истинно ДМ, то у Антона и у Бориса должны быть другие фамилии, значит АМ и БМ ложно. Но если АМ и БМ ложны, то должны быть истинны ВБ и ВТ, но ВБ и ВТ одновременно истинными быть не могут.

Значит остается другой случай: истинно БХ. Этот случай приводит к цепочке умозаключений: 
  
БХ истинно  БМ ложно  ВТ истинно  АТ ложно  ГЧ истинно  ВБ ложно  АМ истинно.

ответ: Борис — Хохлов, Вадим — Тихонов, Гриша — Чехов, Антон — Мишин, Дима — Белкин.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота