ksenia20015
07.02.2022 08:22

Напишите программу с использованием цикла с предисловием while для решения следующей задачи.
Определить в последовательности натуральных чисел среднее арифметическое двухзначных чисел. Ввод чисел в программу осуществляется до тех пор пока не будет введён «0»

В поисковых системах ответы не верные

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Филин4625622
01.01.2023 14:15
Маловато за такую задачку.

Var z:array[1..16] of integer; k:array[1..16] of real; i,p,s:integer; max:real;
Begin
 randomize;
 for i:=1 to 16 do z[i]:=random(101);
 write('Z=');
 for i:=1 to 16 do write(z[i],' ');
 writeln;
 writeln;
 p:=0;
 s:=0;
 for i:=1 to 16 do
   if (i mod 2)<>0 then
     begin
      s:=s+z[i];
      p:=p*z[i];
     end;
 writeln('P=',p);
 writeln('S=',s);
 writeln;
 for i:=1 to 16 do k[i]:=z[i]*exp(ln(i*z[i])/3);
 write('K=');
 for i:=1 to 16 do write(k[i]:0:0,'  ');
 max:=k[1];
 for i:=1 to 16 do
   if k[i]>max then max:=k[i];
 writeln;
 writeln('max=',max:0:0);
 for i:=1 to 16 do
   if k[i]=max then k[i]:=0;
 write('K=');
 for i:=1 to 16 do write(k[i]:0:0,'  ');
End.
0,0(0 оценок)
Ответ:
janelens
14.03.2021 19:24
Начнем с определений.
Сообще́ние — наименьший элемент языка, имеющий идею или смысл, пригодный для общения. Также, форма предоставления информации, совокупность знаков или первичных сигналов, содержащих информацию. Обычно сообщение передается в виде предложения или условного знака.
Да́нные — это результат фиксации, отображения информации на каком-либо материальном носителе, то есть зарегистрированное на носителе представление сведений независимо от того, дошли ли эти сведения до какого-нибудь приёмника и интересуют ли они его
Не так трудно извлечь одну общую черту, а именно ИНФОРМАЦИЮ, а точнее ее представления, я не мастер определений, но я бы сказал так - и то и то в какой то мере является передачи или хранения информации. Хотя сообщения как раз зачастую ориентированы на передачу, в то время как данные хранятся в какой нить базе зачастую даже без просмотра...
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота