АлинаТюлька
17.11.2021 21:57

Задание для выполнения:
1. Составить программу вычисления значения выражения по формуле:
у = (2а+в+5с):(а*5в+с), если а, в – переменные действительного типа, а переменная с – целого типа.
3. Составить программу вычисления площади трапеции с основанием S по формуле S=EF*H, если EF= (BC+AD)/2; H =10
4. Составить программу вычисления общей поверхности и объема круглого конуса, имеющего радиус основания R=12,54 см и длину образующей L=24,83 см. При вычислениях использовать равенства:
S = πR2 + RL; V= 1/3 πR2H, где Н – высота конуса, определяемая по формуле H = √(L^2+R^2 )

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
mediw1
08.01.2021 23:59
25
[0, 0, "a", 1]
[1, 1, "b", 2]
[1, 2, "bb", 3]
[2, 2, "b", 4]
[1, 3, "bbb", 5]
[2, 3, "bb", 6]
[3, 3, "b", 7]
[1, 4, "", 8]
[2, 4, "bbb", 9]
[3, 4, "bb", 10]
[4, 4, "b", 11]
[1, 5, "", 12]
[2, 5, "", 13]
[3, 5, "bbb", 14]
[4, 5, "bb", 15]
[5, 5, "b", 16]
[0, 6, "aa", 17]
[6, 6, "a", 18]
[6, 7, "aa", 19]
[7, 7, "a", 20]
[6, 8, "aaa", 21]
[7, 8, "aa", 22]
[8, 8, "a", 23]
[5, 9, "baaab", 24]
[9, 9, "b", 25]

s = "aaaab"
n = 0
for r in 0...s.size
    for l in 0..r
        t = s[l..r]
        if t.reverse == t
            n += 1
            p [l,r,t,n]
        end
    end
end
0,0(0 оценок)
Ответ:
umma95
28.06.2020 18:28
Var a,b,c,d,x,y,z,y1,z1,y2,z2,nod:integer;
begin
writeln('1-я дробь (числитель и знаменатель):');
readln(a,b);
writeln('2-я дробь (числитель и знаменатель):');
readln(c,d);
y1:=a*d+c*b; y2:=y1;
z1:=b*d; z2:=z1;
while (y2>0)and(z2>0) do
 if y2>z2 then y2:=y2 mod z2 else z2:=z2 mod y2;
nod:=y2+z2;
y1:=y1 div nod; 
z:=z1 div nod;
x:=y1 div z;
y:=y1 mod z;
if x>0 then writeln(x,' ',y,'/',z) else writeln(y,'/',z);
end.

Пример:
1-я дробь (числитель и знаменатель):
1 10
2-я дробь (числитель и знаменатель):
2 5
1/2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота