polinavrn102
06.06.2020 19:59

Переписать программу, выводящую значения функции y=t*x на отрезке [xn; xk] с шагом dx, таким образом, чтобы значения t, xn, xk, dx вводились с клавиатуры.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
WiBBaki
17.01.2023 06:21
// PascalABC.NET 3.2, сборка 1427 от 24.04.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=SeqRandom(ReadInteger('n='),-50,50).Select(n->double(n/10)).ToArray;
  a.ForEach(x->Write(x:0:1,' ')); Writeln;
  Writeln('Сумма отрицательных: ',a.Where(x->x<0).Sum);
  var p:=a.IndexMin;
  var q:=a.IndexMax;
  if p>q then Swap(p,q);
  Writeln('Произведение на интервале: ',
      a[p+1:q].Aggregate(1.0,(x,y)->x*y));
  Writeln('Сортировка:');
  a.Sort; a.ForEach(x->Write(x:0:1,' ')); Writeln;
end.

Пример
n= 13
1.7 -0.8 -1.3 -1.4 5.0 -3.1 -0.7 -2.7 2.6 -4.9 4.0 -2.0 -2.0
Сумма отрицательных: -18.9
Произведение на интервале: -15.2334
Сортировка:
-4.9 -3.1 -2.7 -2.0 -2.0 -1.4 -1.3 -0.8 -0.7 1.7 2.6 4.0 5.0
0,0(0 оценок)
Ответ:
АлфавитABC
08.05.2020 21:20
//Листинг программы и скриншот работы - в приложениях.
//Написано на PascalABC.NET но будет работать в простом Паскале

const
    max = 12;
var N,i,j:byte;
    sum:integer;
    ar:array[1..max, 1..max] of integer;

begin
  writeln('Вычислить сумму диагональных элементов квадратной матрицы');
  write('Введите размер матрицы N = ');
  readln(N);
 
  for i:=1 to N do begin
    for j:=1 to N do begin
      ar[i,j]:=random(-12,12);//любые числа
      write(ar[i,j]:6);
    end;
    writeln();
  end;
 
  sum:=0;
  for i:=1 to n do
    for j:=1 to n do
      if ( i = (n-j+1) ) or ( i = j ) then
        sum:=sum+ar[i,j];

  writeln('Сумма sum = ', sum);
end.

Написать программу которая вычисляет сумму диагональных элементов квадратной матрицы
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота