Инга1702
26.04.2022 09:51

с задачей на Питоне или С++. Думаю, нужно использовать формулу суммы углов выпуклого многоугольника: 180 * (n - 2) Пытался решить перебором по разному, выдаёт Тайм Лимит.

Сама задача:
Даны углы. Определите, какое максимальное кол-во углов из них можно взять, чтобы составить выпуклый многоугольник.

Входные данные
Первая строка содержит целое число
N (3 ≤ N ≤ 100) — количество углов
Вторая строка содержит
N целых чисел Ai (1 ≤ Ai ≤ 179) — величины углов в градусах.

Выходные данные
Выведите одно целое число - ответ на задачу. Если многоугольник невозможно сконструировать из имеющихся углов — выведите 0.

Примеры
входные данные
3
90 60 30
выходные данные
3
входные данные
4
179 1 90 18
выходные данные
0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
GangstaPro
24.10.2022 22:33

#include <iostream>

using namespace std;

int main()

{

   double a, b, c;

   cin >> a >> b >> c;

   if ((a+b > c) && (a+c > b) && (b+c > a))

   {

       if (a == b)

           if (a == c) cout << "Треугольник равносторонний";

           else cout << "Треугольник равнобедренный";

       else if ((a == c) || (b == c )) cout << "Треугольник равнобедренный";

       else cout << "Треугольник разностронний";

   }

   else cout << "Невозможно построить треугольник";

   return 0;

}

0,0(0 оценок)
Ответ:
petryxa333
24.10.2022 22:33

#include <iostream>

using namespace std;

int main()

{

   double a, b, c;

   cin >> a >> b >> c;

   if ((a+b > c) && (a+c > b) && (b+c > a))

   {

       if (a == b)

           if (a == c) cout << "Треугольник равносторонний";

           else cout << "Треугольник равнобедренный";

       else if ((a == c) || (b == c )) cout << "Треугольник равнобедренный";

       else cout << "Треугольник разностронний";

   }

   else cout << "Невозможно построить треугольник";

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота