verik2643
08.01.2023 15:44

Написать программу, выводящую на экран поговорку «Ученье – свет, а неученье – тьма!» — 20 раз.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ангел709
10.10.2020 09:41
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var a,n,i,s:integer;
begin
  write('Число элементов последовательности ');
  readln(n);
  for i:=1 to n do begin
    write(i,' элемент последовательности = ');readln(a);
    if (a mod 2 <>0) then s:=s+a;
  end;
  writeln('Сумма нечетных = ',s);
 end.

Тестовое решение:
Число элементов последовательности 5
1 элемент последовательности = 3
2 элемент последовательности = 2
3 элемент последовательности = 4
4 элемент последовательности = 1
5 элемент последовательности = 5
Сумма нечетных = 9
0,0(0 оценок)
Ответ:
Alevtinka28
24.06.2022 12:21
1. Если имеется в виду язык Pascal, то получим следующее:
var: a;
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
begin
  readln(a);
  b:=a+a;
  writeln (b);
end.

Program50.pas(5) : Неизвестное имя 'b'

2. Попробуем такой вариант на Python

a =int(input())
b = a+a
print(b)

При вводе а получим на выходе 10

Получается, что в Pacal требуется объявлять переменные в секции переменных, или в любом месте программы можно объявить переменную с служебного слова var для PascalABC.net. Первый код можно переписать так, и он будет работать:

var: a;
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
begin
  readln(a);
  var b:=a+a;
  writeln (b);
end.

Рузультат при введенном значении 5 равен 10
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота