slyusarevqaowko3q
24.09.2021 21:55

PYTHON
Монеты
На столе лежат N монеток. Некоторые из них лежат вверх решкой, а некоторые – гербом. Определите минимальное число монеток, которые нужно перевернуть, чтобы все монетки были повернуты вверх одной и той же стороной.
Входные данные
В первой строке записано натуральное число N (1 ≤ N ≤ 100) – число монеток. В каждой из последующих N строк содержится одно целое число – 1 если монетка лежит решкой вверх и 0 если вверх гербом.
Выходные данные
Выведите минимальное количество монет, которые нужно перевернуть.
Пример 1
Ввод:
8 1 0 1 0 1 0 0 0
Вывод:
3

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vershynska
21.11.2021 06:21
#include <stdlib.h>
#include <iostream>
#include <iomanip>
using namespace std;

int main() {
const int n = 5;
double a[n][n];
double m1, m2;

srand(time(0));
for (int i = 0; i < n; i++){
 for (int j = 0; j < n; j++){
a[i][j]=-20 + (101.0 / RAND_MAX) * rand();
cout << fixed << setw (7) << setprecision (2) << a[i][j];
 }
cout <<endl;
}
m1=a[0][0];
m2=a[0][n-1];
for (int i = 1; i < n; i++){
 if (a[i][i]>m1) m1=a[i][i];
 if (a[i][n-i-1]>m2) m2=a[i][n-i-1];
 }
 cout << "m1=" << m1 << "  m2=" << m2 << endl;
}
  37.11  71.19  25.77  53.53  35.74
  39.90  63.69  11.67  70.38  -4.10
  64.46  52.37  35.03  42.58  69.18
  44.22   8.46  13.23  71.17   3.10
   6.83  65.07  75.24  21.61  37.22
m1=71.17  m2=70.38
0,0(0 оценок)
Ответ:
chumaeva791
31.08.2022 14:05

Объяснение:

1) Происходит 16000 измерений в секунду, на одно измерение отводится 16 бит, значит, на секунду необходимо 16000 * 16 бит = 16000 * 2 байт = 32000 байт, а на 30 секунд - 30 * 32 000 байт = 960 000 байт = 937,5 Кб

2) Необходимо 1 760 000 байт на 20 секунд, т.е. 1 760 000 / 20 = 88 000 байт. Есть 2 канала по 16 бит = 2 байта, одно измерение занимает 2 * 2 = 4 байта, тогда всего измерений в секунду 88 000 / 4 = 22 000, частота дискретизации 22 000 Гц.

3) 2 * 1 * 48000 * 16 бит = 48000 * 4 байт = 187,5 Кб

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота