temka32984
09.08.2022 07:26

PYTHON
Делители числа
Напишите программу, которая отображает все делители числа N.
Входные данные: вводится единственное натуральное число n.
Выходные данные: на одной строке вывести все делители данного числа. Используйте для вывода параметр
end = " " с командой print(). Пример: print(x, end = " ").
Пример 1
Ввод:
12
Вывод:
1 2 3 4 6 12
В пайтоне

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
syrmilyj
14.10.2020 07:23

a = int(input("Введи число: "))

for i in range(1,a+1):

   if a%i == 0:

       print(i,end = " ")


PYTHONДелители числа Напишите программу, которая отображает все делители числа N. Входные данные: вв
PYTHONДелители числа Напишите программу, которая отображает все делители числа N. Входные данные: вв
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота