250alina250
15.08.2022 16:16

Написать подпрограмму, которая для целого числа определяет сумму разрядов «тысяч» и
«десятков» в его записи (например, 2347  2+4=6). В основной программе ввести два целых числа.
С подпрограммы определить суммы в двух введенных числах и распечатать их.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
АляЛайк
10.12.2022 18:26

PascalABC.NET

#1

function Y(x:integer) := 2*((x+2)**2)+5.5*(x+2) - 3;

begin

 var Xes := Range(3, 25);

 Xes.Tabulate(p -> Y(p)).Println;

end.

#2

const PASS = '123ab';

begin

 var rpass := Readstring('Pass: ');

 while rpass <> PASS do begin

   rpass := Readstring('Wrong pass. Try again: ');

 end;

 print('Correct password. Welcome');

end.

#3

begin

//Сначала читаем цифру, которую надо удалить, а уже потом число.

 var X := ReadChar();

 var number := ReadInteger().ToString.ToCharArray.ToList;

 while number.Contains(X) do number.Remove(X);

 number.JoinIntoString.Println;

end.

#4

begin

 var X := ReadInteger();

 Print((x div 100)+(x mod 100));

end.

Объяснение:

0,0(0 оценок)
Ответ:
papa63428
04.04.2021 12:00
//7.Написать программу на Паскале вычисления значения функции(х^2 при х>0 х-12 при х≤0)

var
x:integer;
begin
writeln('Введите x');
readln(x);
if x>0 then writeln('ответ ', power(x,2))
else writeln('ответ ', x-12);
end.

//8.Написать программу на Паскале нахождения периметра произвольного четырехугольника, данные вводить с клавиатуры.

var
a,b,c,d:integer;
begin
writeln('Введите a,b,c,d');
readln(a,b,c,d);
writeln('P= ', a+b+c+d);
end.

//9.Написать программу на Паскале вычисления значения выражения у=15х3+3х2-6

var
x:integer;
begin
writeln('Введите x');
readln(x);
writeln('ответ ', 15*power(x,3)+3*power(x,2)-6)
end.

//10.Написать программу на Паскале вычисления значения функции(х^2+5х-4 при х>3х при х≤3)

var
x:integer;
begin
writeln('Введите x');
readln(x);
if x>3 then writeln('ответ ', power(x,2)+5*x-4)
else writeln('ответ ', x);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота