BlackTaiger
23.06.2021 00:51

Напишите программу угадывания пароля с использованием цикла WHILE
(повторять ввод пароля пользователем, пока он не совпадёт с тем, который "зашифрован в программе")

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vladik2ppp
14.10.2020 06:40

var

pin : integer;

readPin : integer;

 

begin

 pin := 1234; //здесь напишешь  свой пин

  writeln('Write Pin :');

 readln(readPin);

 while readPin <> pin do begin

   writeln('Error wrong pin!');

   readln(readPin);

 end;

end.

Объяснение:

Вот

0,0(0 оценок)
Ответ:
Kristinkasssd001
14.10.2020 06:40

import random

code = ["954321"]

mineC = []

final = ""

i = 0

while True:

   while i < 6:

       wordC = random.randint(0, 9)

       mineC.append(wordC)

       i += 1

   if mineC != code:

       print(mineC)

       mineC.clear()

   if mineC == code:

       for i in mineC:

           final += i

       break

Работает только с паролями с цифрами

иначе придется выстраивать буквы по індексу и вызывать их так

   

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота