Dhffhjh
27.03.2023 12:51

Программирование линейных алгоритмов»составь программу, позволяющую посчитать сумму цифрвводимого с клавиатуры двухзначного числа. длясоставления программы воспользуйся операциями div и mod.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Shady2002
24.05.2020 01:26

числа задаются автоматом через  random

Объяснение:

var

 a : array [1..40] of integer;

 i, m, ind : integer;

begin

 randomize;

 for i := 1 to 40 do begin

   a[i] := random(100);

   if i mod 2 = 0 then write(a[i]:2, ' ')

   else write(a[i]:2, '__');

   if i mod 10 = 0 then writeln();

 end;

 m := 200;

 ind := -1;

 i := 1;

 repeat begin

   if m > (a[i]+a[i+1]) then begin

     m := (a[i]+a[i+1]);

     ind := i;

   end;

   i := i+2;

 end

 until i > 40;

 

 writeln('----- ', round((ind+1)/2) ,' пара минимальная -----');

 writeln(a[ind], ' ', a[ind+1]);

end.


Дан целочисленный массив из 40 элементов. Напишите программу на паскале, которая находит и выводит п
0,0(0 оценок)
Ответ:
Markos14
24.05.2020 01:26

Объяснение:

Дан целочисленный массив из 40 элементов. Элементы массива могут принимать целые значения от –10 000 до 10 000 включительно. Опишите на русском языке или на одном из языков программирования алгоритм, который находит и выводит пару с наименьшей суммой среди непересекающихся пар соседних элементов. То есть, первая пара - 1-й и 2-й элементы, вторая пара - 3-й и 4-й элементы, и т.д.

Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота