ezio19
12.10.2022 12:03

Допишите программный код, очень Задача.Написать программу, которая проверяет введенный возраст человека и определяет возрастной его период. При вводе ошибочных данных программа выдает сообщение «Не верно введён возраст».
1. Составим словесную модель:
По данным Всемирной организации здравоохранения
0-12 - детство
13-17 - юность
18-44 - молодость
45-60 - средний возраст
61-75 - пожилой
76-90 - старческий
91+ - долгожитель

procedure TForm1.Button1Click(Sender: TObject);

var …………………………..;

begin

N:= StrToInt (Edit1.Text);

case ……… of

0..12 : Label3.Caption:= ‘……………………………';

……………………………………………………………………..

……………………………………………………………………..

……………………………………………………………………..

……………………………………………………………………..

……………………………………………………………………..

……………………………………………………………………..

……………………………………………………………………..

Else Label3.Caption:= 'Не верно введен возраст';

end;

end;

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
наира203
12.04.2021 11:39
Const
  n=8;
var
  aNam, aFam, aDat: array[1..n] of string;
  i: integer;

begin
  aNam[1]:='Олег'; aFam[1]:='Бубенков'; aDat[1]:='1993';
  aNam[2]:='Игорь'; aFam[2]:='Бросов'; aDat[2]:='1991';
  aNam[3]:='Тимур'; aFam[3]:='Наружный'; aDat[3]:='1961';
  aNam[4]:='Анастасия'; aFam[4]:='Боброва'; aDat[4]:='1985';
  aNam[5]:='Михаил'; aFam[5]:='Тапаров'; aDat[5]:='1957';
  aNam[6]:='Евгений'; aFam[6]:='Костарева'; aDat[6]:='1992';
  aNam[7]:='Мария'; aFam[7]:='Никитин'; aDat[7]:='1977';
  aNam[8]:='Ксения'; aFam[8]:='Бабенкова'; aDat[8]:='1978';
  writeln('Лица, чьи фамилии начинаются на букву "Б"');
  for i := 1 to n do
    if aFam[i][1] = 'Б' then
      writeln(aNam[i],' ',aFam[i], ' (', aDat[i], ')')
end.

тестовый прогон:

Лица, чьи фамилии начинаются на букву "Б"
Олег Бубенков (1993)
Игорь Бросов (1991)
Анастасия Боброва (1985)
Ксения Бабенкова (1978)

Возможна также более "современная" запись программы

const
  n = 8;

type
  tP = record
    Nam: string;
    Fam: string;
    Dat: string
  end;

var
  M: array[1..n] of tP;
  i: integer;

begin
  with M[1] do begin Nam := 'Олег'; Fam := 'Бубенков'; Dat := '1993' end;
  with M[2] do begin Nam := 'Игорь'; Fam := 'Бросов'; Dat := '1991' end;
  with M[3] do begin Nam := 'Тимур'; Fam := 'Наружный'; Dat := '1961' end;
  with M[4] do begin Nam := 'Анастасия'; Fam := 'Боброва'; Dat := '1985' end;
  with M[5] do begin Nam := 'Михаил'; Fam := 'Тапаров'; Dat := '1957' end;
  with M[6] do begin Nam := 'Евгений'; Fam := 'Костарева'; Dat := '1992' end;
  with M[7] do begin Nam := 'Мария'; Fam := 'Никитин'; Dat := '1977' end;
  with M[8] do begin Nam := 'Ксения'; Fam := 'Бабенкова'; Dat := '1978' end;
  writeln('Лица, чьи фамилии начинаются на букву "Б"');
  for i := 1 to n do
    With M[i] do begin
      if Fam[1] = 'Б' then
        writeln(Nam, ' ', Fam, ' (', Dat, ')')
    end
end.
0,0(0 оценок)
Ответ:
dendenisenko2
12.04.2021 11:39
Const
  n=8;
var
  aNam, aFam, aDat: array[1..n] of string;
  i: integer;

begin
  aNam[1]:='Олег'; aFam[1]:='Бубенков'; aDat[1]:='1993';
  aNam[2]:='Игорь'; aFam[2]:='Бросов'; aDat[2]:='1991';
  aNam[3]:='Тимур'; aFam[3]:='Наружный'; aDat[3]:='1961';
  aNam[4]:='Анастасия'; aFam[4]:='Боброва'; aDat[4]:='1985';
  aNam[5]:='Михаил'; aFam[5]:='Тапаров'; aDat[5]:='1957';
  aNam[6]:='Евгений'; aFam[6]:='Костарева'; aDat[6]:='1992';
  aNam[7]:='Мария'; aFam[7]:='Никитин'; aDat[7]:='1977';
  aNam[8]:='Ксения'; aFam[8]:='Бабенкова'; aDat[8]:='1978';
  writeln('Лица, чьи фамилии начинаются на букву "Б"');
  for i := 1 to n do
    if aFam[i][1] = 'Б' then
      writeln(aNam[i],' ',aFam[i], ' (', aDat[i], ')')
end.

тестовый прогон:

Лица, чьи фамилии начинаются на букву "Б"
Олег Бубенков (1993)
Игорь Бросов (1991)
Анастасия Боброва (1985)
Ксения Бабенкова (1978)

Возможна также более "современная" запись программы

const
  n = 8;

type
  tP = record
    Nam: string;
    Fam: string;
    Dat: string
  end;

var
  M: array[1..n] of tP;
  i: integer;

begin
  with M[1] do begin Nam := 'Олег'; Fam := 'Бубенков'; Dat := '1993' end;
  with M[2] do begin Nam := 'Игорь'; Fam := 'Бросов'; Dat := '1991' end;
  with M[3] do begin Nam := 'Тимур'; Fam := 'Наружный'; Dat := '1961' end;
  with M[4] do begin Nam := 'Анастасия'; Fam := 'Боброва'; Dat := '1985' end;
  with M[5] do begin Nam := 'Михаил'; Fam := 'Тапаров'; Dat := '1957' end;
  with M[6] do begin Nam := 'Евгений'; Fam := 'Костарева'; Dat := '1992' end;
  with M[7] do begin Nam := 'Мария'; Fam := 'Никитин'; Dat := '1977' end;
  with M[8] do begin Nam := 'Ксения'; Fam := 'Бабенкова'; Dat := '1978' end;
  writeln('Лица, чьи фамилии начинаются на букву "Б"');
  for i := 1 to n do
    With M[i] do begin
      if Fam[1] = 'Б' then
        writeln(Nam, ' ', Fam, ' (', Dat, ')')
    end
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота