danikpro200201
07.02.2020 14:56

Ребят в паскале набрать. Считать произведение (при этом в программе нужно указать P=1) введенных с
клавиатуры чисел до тех пор, пока не будет введено отрицательное число.
Составить программу.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Tasuhka
24.08.2020 12:18

var

a:boolean;

p,new:integer;

begin

 a:=TRUE;

 p:=1;

 while a do

 begin

 readln(new);

 if new >= 0

 then p:= p * new

 else a:=FALSE;

 end;

 writeln(p);

end.


Ребят в паскале набрать. Считать произведение (при этом в программе нужно указать P=1) введенных с к
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота