Bananchik26
16.11.2022 06:57

На С++

Даны два числа n и m. Создайте двумерный массив A[n][m], заполните его таблицей умножения A[i][j]=i*j и выведите на экран. При этом нельзя использовать вложенные циклы, все заполнение массива должно производиться одним циклом.
Входные данные
Программа получает на вход два числа n и m – количество строк и столбцов, соответственно.

Выходные данные
Программа должна вывести полученный массив. Числа разделяйте одним пробелом.

Примеры
входные данные
3 3
выходные данные
0 0 0
0 1 2
0 2 4

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
linakovtunenko1
20.09.2021 19:50
Исходное число 665675757
1)665675757:2=332837878 и в остатке 1
значит пишем 1
2)332837878:2=166418939 и в остатке 0
значит пишем 0
3)166418939:2=83209469 и в остатке 1
значит пишем 1
4)83209469:2=41604734 и в остатке 1
значит пишем 1
5)41604734:2=20802367 и в остатке 0
значит пишем 0
6)20802367:2=10401183 и в остатке 1
значит пишем 1
7)10401183:2=5200591 и в остатке 1
значит пишем 1
8)5200591:2=2600295 и в остатке 1
значит пишем 1
9)2600295:2=1300147 и в ост 1
зн пишем 1
10)1300147:2=650073 и в ост 1
зн пишем 1
11)650073:2=325036 и в ост 1
зн пишем 1
12)325036:2=162518 и в ост 0
зн  пишем 0
13)162518:2=81259 и в ост 0
зн пишем 0
14)81259:2=40629 и в ост 1
зн пишем 1
15)40629:2=20314 и в ост 1
зн пишем 1
16)20314:2=10157 и в ост 0
зн пишем 0
17)10157:2=5078 и в ост 1
зн пишем 1
18)5078:2=2539 и в ост 0
зн пишем 0
19)2539:2=1269 и в ост 1
зн пишем 1
20)1269:2=634 и в ост 1
зн пишем 1
21)634:2=317 и в ост 0
зн  пишем 0
22)317:2=158 и ост 1
зн пишем 1
23)158:2=79 и ост 0
зн пишем 0
24)79:2=39 и ост 1
зн пишем 1
25)39:2=19 и ост 1
зн пишем 1
26)19:2=9 и ост 1
зн пишем 1
27)9:2=4 и ост 1
зн пишем 1
28)4:2=2 и ост 0
зн пишем 0
29)2:2=1 и ост 0
зн пишем 0
30)1:2=0 и ост 1
зн пишем 1
число в двоичной системе 10110111110011010110101111001
0,0(0 оценок)
Ответ:
sladkoegka03
02.09.2020 23:01
Самое худшее, что можно придумать, это сделать именно процедуру.
Ниже вариант с процедурой, а потом другой, без процедур. Можно сравнить...

// PascalABC.NET 3.2, сборка 1509 от 27.07.2017
// Внимание! Если программа не работает, обновите версию!

Вариант с процедурой

procedure MassAvg(var r:real);
begin
  r:=ReadSeqInteger('Вводите:',ReadInteger('n=')).Average
end;

begin
  var avg:real;
  for var i:=1 to 3 do begin
    MassAvg(avg);
    Writeln('Среднее значение: ',avg)
    end
end.

Вариант без процедур и функций

begin
  for var i:=1 to 3 do begin
    Writeln('Среднее значение: ',
        ReadSeqInteger('Вводите:',ReadInteger('n=')).Average)
    end
end.

Результат
n= 7
Вводите: -5 4 11 8 0 5 4
Среднее значение: 3.85714285714286
n= 5
Вводите: 100 32 52 43 19
Среднее значение: 49.2
n= 4
Вводите: 6 6 8 7
Среднее значение: 6.75
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота