Юлька6488262
25.09.2020 07:34

информатика 10 класс.
написать программу в паскаль, которая ежедневно в течение 1 месяца, заносит данные по температуре в полдень в базу данных. (Данные задать рандомно. Диапазон температур от 7 до 23 градусов) И в конце месяца выводит данные по средней температуре за месяц.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
bryazgin98p06isp
28.09.2020 21:11

Конечно, для такой популярной задачи есть готовая имплиментация - например, она есть в пакете numpy, искомая функция numpy.std. Единственное, чтобы в знаменателе был n - 1, а не n, нужно добавить ddof=1

Можно посчитать и руками (и проверить, совпадает ли результат)

# python 3

from math import sqrt # квадратный корень

from numpy import std # готовая реализация для проверки

x = []

while True:

   temp = int(input()) # считываем значение во временную переменную

   x.append(temp) # добавляем в массив

   if temp == 0: # если это 0, то это последний элемент массива

       break

n = len(x) # количество элементов

s = sum(x) / n # среднее арифметическое

s2_1 = 0

for el in x:

   s2_1 += (el - s) ** 2 # вычисление суммы квадратов, вариант 1

s2_2 = sum((el - s) ** 2 for el in x) # вычисление суммы квадратов, вариант 2

std_1 = sqrt(s2_1/(n - 1))

std_2 = sqrt(s2_2/(n - 1))

std_3 = std(x, ddof=1)

print(std_1)  # первый вывод - вариант с вычислением суммы квадратов по методу 1

print(std_2)  # второй вывод - вариант с вычислением суммы квадратов по методу 2

print(std_3) # третий вывод - готовая функция из библиотеки numpy

Пример ввода:

1

1

1

1

1

100

0

Пример вывода:

37.48332962798263

37.48332962798263

37.48332962798263

0,0(0 оценок)
Ответ:
Tamik7895
23.07.2022 21:34

Линейный алгоритм или следование – это тип алгоритма, в котором последовательность действий не меняется в его процессе выполнения.

Предложение языка программирование задающее описание действия называется оператором. Операторы бывают простые и структурные.

Простыми называются операторы, которые описывают одно действие. Такие операторы используют для составления простейших линейных алгоритмов.

В программе линейный алгоритм реализуется последовательным размещением операторов.

Разветвляющийся алгоритм - алгоритм, содержащий хотя бы одно условие, в результате проверки которого ЭВМ обеспечивает переход на один из двух возможных шагов.

Укр:  

Лінійний алгоритм або проходження - це тип алгоритму, в якому послідовність дій не змінюється в його процесі виконання.

Пропозиція мови програмування задає опис дії називається оператором. Оператори бувають прості і структурні.

Простими називаються оператори, які описують одну дію. Такі оператори використовують для складання найпростіших лінійних алгоритмів.

У програмі лінійний алгоритм реалізується послідовним розміщенням операторів.

Розгалужується алгоритм - алгоритм, що містить хоча б одна умова, в результаті перевірки якого ЕОМ забезпечує перехід на один з двох можливих кроків.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота