alice108
24.01.2020 04:34

Посмотрите на следующую программу: *
задание - my list (bananas oranges frappes pain apples appels )
print my list выберите оператора
my_list.sort() my_list.reverse()
my_list.sort()
my_list.reverse()
my_list.remove("grapes")​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vitas40
23.07.2020 16:56
Var
  m,n,i,j,max,min,imx,imn,jmn,jmx,k,p:integer;
  s:real;
  a:array[,]of integer;
begin
write('Число строк: ');
readln(m);
write('Число столбцов: ');
readln(n);
setlength(a,m+1,n+1);
for i:=1 to m do
  begin
  writeln('Вводите элементы строки ',i,' по одному');
  for j:=1 to n do    readln(a[i,j]);
  end;
min:=a[1,1];
max:=a[1,1];
imn:=1;
jmn:=1;
imx:=1;
jmx:=1;
for i:=1 to m do
  for j:=1 to n do
    begin
    if a[i,j]<min then
      begin
      min:=a[i,j];
      imn:=i;
      jmn:=j;
      end;
    if a[i,j]>max then
      begin
      max:=a[i,j];
      imx:=i;
      jmx:=j;
      end;
    end;
p:=a[imn,jmn];
a[imn,jmn]:=a[imx,jmx];
a[imx,jmx]:=p;
writeln('Измененный массив:');
for i:=1 to m do
  begin
  for j:=1 to n do    write(a[i,j]:5);
  writeln;
  end;
write('Введите номер строки: ');
readln(i);
for j:=1 to n do
  if a[i,j]<0 then
    begin
    s:=s+a[i,j];
    k:=k+1;
    end;
writeln('Ср.ариф. отр.чисел в строке: ',s/k);  
end. 
0,0(0 оценок)
Ответ:
mikhdina24
06.06.2021 06:36

Код + скриншот (код и вывод компилятора). Строки с #... - комментарии. Если хотите, что бы показывался весь процесс работы программы - уберите только "#". Если не нужно - можете удалить строки с #... (не обязательно):

N = int(input("N = "))

fact_N = 1

for i in range(1,N+1):

   fact_N *= i

#print("Factorial N = ",fact_N)

count_dividers = 0

for divider in range(1,fact_N+1):

   if (fact_N % divider == 0):

       count_dividers += 1

#        print(count_dividers,"divider = ",divider)

print("Amount of dividers for '",N,"' - ",count_dividers)


Напишите программу на питоне Делители факториала По заданному натуральному числу N необходимо вычисл
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота