cocscocsovich3
04.12.2020 13:20

Нужно написать программу по информатики.

До першого класу школи приймають учнів, яким виповнилось 7 років, та які проживають по мікрорайону школи. Вказати, чи може учень вступити до цієї школи, якщо дано його вік та відомо чи проживає він по мікрорайону школи.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Metalmekid
01.06.2022 20:55
Var a: byte; b:integer;
Begin 
writeln('Введите день месяца');
readln(b);
writeln('Введите номер месяца');   
Readln(a);    
          Case a of        
1: writeln(b,' янавря');        
2: writeln(b,' февраля');      
3: writeln(b,' марта ');        
4: writeln(b,' апреля ');      
5: writeln(b,' мая');      
6: writeln(b,' июня ');        
7: writeln(b,' июля');       
8: writeln(b,' августа');     
9: writeln(b,' сентября');     
10: writeln(b,' октября');     
11: writeln(b,' ноября');       
12: writeln(b,' декабря');     
else writeln('Месяца №', a,'нет');   
end;       
end.
0,0(0 оценок)
Ответ:
yanachor25
11.04.2022 06:56
1. Вот так это пишется с функцией

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
function IsPrime(n:integer):boolean;
begin
  if n<4 then Result:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    Result:=not found
    end
end;

begin
  Writeln('k=',ArrRandom(ReadInteger('n='),1,999).Println.
    Where(x->IsPrime(x)).Count)
end.

Тестовое решение:
n= 10
401 828 780 444 694 965 23 341 673 875
k=3

2. А вот так это пишется с процедурой

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
procedure IsPrime(n:integer; var res:boolean);
begin
  if n<4 then res:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    res:=not found
    end
end;

begin
  var a:=ArrRandom(ReadInteger('n='),1,999); a.Println;
  var k:=0;
  var prime:boolean;
  foreach var e in a do begin
    IsPrime(e,prime);
    if Prime then Inc(k)
    end;
  Writeln('k=',k)
end.

Тестовое решение:
n= 12
199 43 71 365 417 904 170 212 694 103 161 689
k=4
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота