katemurzik
16.03.2021 02:09

Дана последовательность целых чисел написать программу которая должна выяснить является ли эта последовательность убывающей используйте паскаль,если можно,то с командой array

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
2Сергей5751
08.06.2020 03:28

program raf105;

var a:array[1..100] of integer;

i,b:integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

i:=1;

readln(a[i]);

while a[i]<>0 do

begin

 i:= i+1;

 readln(a[i]);

 if a[i]>=a[i-1]

   then b:=1;

end;

if b=1

 then writeln('Последовательность не является убывающей.')

 else writeln('Последовательность убывающая.');

end.

Программа написана на языке PascalABC.NET

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота