TamiDobro
05.12.2020 00:25

Написать программу по нахождению суммы N четных чисел. ( S=2+4+6+…+2N).
2) Написать программу для нахождения введенных N чисел (P = P*a).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Лиза4217
07.11.2020 09:19
Пусть X - любая из гласных (а или е), Y - любая из согласных (б, в, г, д).
Тогда слова, в которых гласных больше, чем согласных, будут иметь вид:
- количество таких слов 2^5 = 32
Y - количество таких слов 2^4*4 = 16*4 = 64
XXXYX - количество таких слов 2^4*4 = 16*4 = 64
XXYXX - количество таких слов 2^4*4 = 16*4 = 64
XYXXX - количество таких слов 2^4*4 = 16*4 = 64
Y - количество таких слов 2^4*4 = 16*4 = 64
XXXYY - количество таких слов 2^3*4^2 = 8*16 = 128
XXYYX - количество таких слов 2^3*4^2 = 8*16 = 128
XYYXX - количество таких слов 2^3*4^2 = 8*16 = 128
YYXXX - количество таких слов 2^3*4^2 = 8*16 = 128
XXYXY - количество таких слов 2^3*4^2 = 8*16 = 128
XYXYX - количество таких слов 2^3*4^2 = 8*16 = 128
YXYXX - количество таких слов 2^3*4^2 = 8*16 = 128
XYXXY - количество таких слов 2^3*4^2 = 8*16 = 128
YXXYX - количество таких слов 2^3*4^2 = 8*16 = 128
YXXXY - количество таких слов 2^3*4^2 = 8*16 = 128
Итого: 32+5*64+10*128 = 32+320+1280  = 1632
0,0(0 оценок)
Ответ:
лика20042
11.10.2020 08:04
// PascalABC.NET 3.3, сборка 1573 от 04.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var k:=3;
  Writeln('*** Исходный массив ***');
  var a:=MatrRandom(k,6,-20,20);
  a.Println(4); Writeln(4*a.ColCount*'-');
  var n:=ReadInteger('Какую строку удалить (1-'+k+')?');
  Assert(n.Between(1,k),'Введено неверное значение');
  var r:=a.Row(k-1); // последняя строка
  SetLength(a,k-1,a.ColCount); // теперь строк на одну меньше
  if n<k then begin
    for var i:=n-1 to k-3 do
      a.SetRow(i,a.Row(i+1));
    a.SetRow(k-2,r)
    end;
  Writeln(4*a.ColCount*'-'); a.Println(4)
end.

Примеры
*** Исходный массив ***
  -8   3 -10  -5  -8  11
  14  -5 -19  -6 -19 -15
   0 -11  11   3  -6 -12

Какую строку удалить (1-3)? 1

  14  -5 -19  -6 -19 -15
   0 -11  11   3  -6 -12

*** Исходный массив ***
  11 -14  -3  18  19  -9
 -11  19   8  20 -19  19
 -20  13   3 -13  13   1

Какую строку удалить (1-3)? 3

  11 -14  -3  18  19  -9
 -11  19   8  20 -19  19
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота