apple122
24.01.2021 21:32

Напишите программу, определяющую, является ли введенная строка палиндромом

(т. е. читается одинаково слева-направо и справа-налево).

а) с учетом пробелов (например, таким палиндромом будет строка «дом мод»);
На python​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
olya355
14.10.2020 05:57

string = input()

palindrome = True

for i in range(1, len(string) // 2):

   if string[i - 1] != string[-i]:

       palindrome = False

print('Да' if palindrome else 'Нет')

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота