soung1
09.03.2022 15:15

Pascal. Написать программу, которая позволяет транспонировать матрицу. Размерность вводится с клавиатуры, значения случайные числа от -10 до 10.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Азяка21
14.10.2020 05:33

program mtr1;

const N=10;

type iint:1..10;

       matrix: array [iint,iint] of integer;

var a: matrix;

     i,j: iint;

     m:iint;

    v:integer;

begin

       readln (m);

      randomize;

      (* заполнение матрицы *)

      for i:=1 to m do

     for j:=1 to m do

    a[i,j] := random(21)-10;

    for i:=1 to m do

    for j:=i to m do

    begin

            if i=j then

               continue;

     v:= a[i,j];

      a[i,j] := a[j,i];

      a[j,i] := v;

     end;

     for i:=1 m do

     begin

     for j:=1 to m do

     write(a[i,j],'  ');

     writeln;

     end;

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота