2345Pomogite2345
27.10.2020 13:43

Написать программу на ЯП Паскаль: Подсчитать сумму всех цифр, которые встречаются в строке. (Указания: рассмотреть строку посимвольно, построить условие, проверяющее, является ли очередной символ числовым, при истинности данного условия преобразовать символ в число и добавить в сумму)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
hhhhh7777
27.03.2020 18:16
#include <iostream>
using namespace std;
int main()
{ setlocale(0,"");
int a;
cout<<"введите значение погоды"<<endl;
cout<<"1-тепло"<<endl;
cout<<"2-жарко"<<endl;
cout<<"3-холодно"<<endl;
cout<<"4-колотун"<<endl;
cin>>a;
switch (a)
{
case 1: cout<<"вы можете одеть джинсы и футболку"<<endl; break;
case 2: cout<<"вы можете одеть шорты и майку "<<endl; break;
case 3: cout<<"вы можете одеть штаны и толстовку "<<endl; break;
case 4: cout<<"вы можете одеть куртку и свитер с подштанниками и ватными штанми "<<endl;
 break;
}
return 0;
}
0,0(0 оценок)
Ответ:
olhkasianchuk
11.10.2020 02:05
//прога на Pascal`e
type
  myrec = record
  rost : byte;
  ves : byte;
  end;
var
  mas : array of myrec;
  n, i : byte;
  sumves, sumrost : longint;
begin
write ('Введите кол-во учеников: ');
readln (n);
setLength (mas, n);
  for i:=0 to n-1 do
  begin
  write ('Введите вес ', i+1, '-го ученика: ');
  readln (mas[i].ves);
  inc (sumves, mas[i].ves);
  write ('Введите рост ', i+1, '-го ученика: ');
  readln (mas[i].rost);
  inc (sumrost, mas[i].rost);
  end;

write ('Средний вес учеников: ', sumves / n, '; Средний рост: ', sumrost / n)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота