КарКарыч6666
20.10.2022 07:56

Дан двумерный массив размером mxn массив заполнен случайными числами от 5 до 10. найти произведение значений по главной диагонали и сумму по побочной диагонали.нужно написать программу в паскале к этому. !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
маридиана
08.06.2020 02:02

var

A : array [1..999, 1..999] of Integer;

p, s, i, j, m, n: Integer;

begin

// Инициализация переменных для суммы и произведения

s:= 0;

p:= 1;

Write('Введите количество строк - ');

ReadLn(m);

Write('Введите количество столбцов - ');

ReadLn(n);

// Заполнение

for i:=1 to m do

for j:=1 to n do

A[i,j]:=Random(6)+5;

// Вывод массива

for i:=1 to m do

begin

for j:=1 to n do

Write(A[i,j]:3);

WriteLn();

end;

// Подсчёт произведения и суммы

for i:= 1 to m do

begin

j:= i;

s+= A[m-i+1,j];

p*= A[i,j];

end;

WriteLn('Произведение = ', p);

WriteLn('Сумма = ', s);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота