lollo2003
28.05.2023 12:41

1) Напишите программу печати квадратов всех натуральных чисел (тип переменной – integer) от 1 до n.
1) Даны целые числа K и N (N > 0). Вывести N раз число K.
3) Даны два целых числа A и B (A < B). Найти сумму всех целых чисел от A до B включительно

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mehili
15.11.2021 08:03

import java.util.Scanner;

import java.util.ArrayList;

public class multi {

   public static void main(String[] args) {

       int counter = 0;

       ArrayList<Integer> arr = new ArrayList<>();

       Scanner scanner = new Scanner(System.in);

       for (int i = 1; i<=6; i++) {

           while (true) {

               System.out.print("Введите " + i + "-е значение: ");

               int v = Integer.parseInt(scanner.nextLine());

               

               if (v == 0) counter++;

               else counter = 0;

               if (i == 6 && counter >= 6) {

                   System.out.println("Все значения не могут быть равны 0!");

                   continue;

               }

               

               arr.add(v);

               break;

           }

       }

       System.out.println(arr);

       System.out.println(multiply(arr));

   }

   public static Integer multiply(ArrayList<Integer> arr) {

       int v = 0;

       for (int i : arr) {

           if (i != 0) {

               if (v == 0) v = i;

               else v *= i;

           }

       }

       return v;

   }

}

0,0(0 оценок)
Ответ:
рай34
09.05.2021 15:51

Графический интерфейс (Graphical User Interface или GUI) создан для более удобного взаимодействия с пользователем (в отличии от просто командно-текстового взаимодействия или консоли)

Надпись, иконка - элементы для вывода информации текстовой и графической соответственноКнопка - базовый функциональный элемент для запуска определенной команды. Может содержать иконки и надписиТекстовое поле - одно/много-строчное, для вывода и ввода текстовой информации. Пункт меню - вариация кнопкиМеню - обычно древовидное объединение нескольких пунктов менюОбласти для вывода изображений и видеоКурсор мыши - элемент для удобного взаимодействия со всем вышеперечисленным

Не совсем точно, но более менее понятно. Так или иначе из комбинации этих элементов и состоят все графические интерфейсы

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота