Аня5сплюсом
27.05.2020 20:35

Написать программу по данной блок-схеме.Марс Алгоритмика

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Помидоркин001
27.07.2021 15:02

#include <iostream>

 

using namespace std;

 

int main() {

   const char* s = "one two three four five six seven";

 

   const char* w = 0;

   int max_size = 0;

   int word_size = 0;

   for (int i = 0; s[i]; i++) {

       if (s[i] != ' ') {

           word_size++;;

       } else if ((s[i] == ' ') || !s[i + 1]) {

           if (word_size > max_size) {

               max_size = word_size;

               w = s + i - word_size;

           }

           word_size = 0;

       }

   }

   

   for (int i = 0; i < max_size; i++) {

       std::cout << w[i];

   }

   std::cout << "\n";

   

   return 0;

}

0,0(0 оценок)
Ответ:
Gu1ya04
24.05.2020 06:40

правильный с синтаксической точки зрения код:

ConsoleColor text = ConsoleColor.Red;  

string myProgrammName = "Крутая прога от меня!";

string s = "Чтобы она заработала, нужно дорого заплатить.";

int cost1 = 15000;

char currency = '$';  

Console.Title = myProgrammName;  

Console.WriteLine(s);

Console.ForegroundColor = text;

Console.Write(cost1);

Console.ResetColor();

Console.WriteLine(currency);

double cost = 15.5;

Console.WriteLine("...");

Console.ReadLine();

Console.Write("Ну или хотя бы ");

text = ConsoleColor.Green;

Console.ForegroundColor = text;

Console.WriteLine(cost);

объяснение ошибок по строкам:

1) неверное объявление переменной text

2) объявлена переменная целого типа, а значение присвоено как переменной строкового типа

3) не выбрано имя переменной и пропущена точка с запятой

4) объявлена переменная целого типа, а значение присвоено как переменной строкового типа

5) не определен тип переменной

6) будет выводить строку myProgrammName вместо значения переменной myProgrammName

7) будет выводить строку string вместо значения переменной.

8) нет ошибки

9) неверное имя переменной

10) нет ошибки

11) нет ошибки

12) неверный тип переменной

13)нет ошибки

14)нет ошибки

15)нет ошибки

16) пропущено ConsoleColor

17) нет ошибки

18) нет ошибки

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота