WERTO124
19.06.2022 06:32

Тип чисел: Integer,

функция: 10*(x^2),

размерность массива: 3x8;

Написать программу на ЯП (язык программирования) Pascal, в которой бы объявлялся массив чисел заданного типа и размерности. Программа должна вывести на экран все элементы массива в виде последовательности или матрицы, при этом к каждому элементу массива должна быть применена заданная математическая функция.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vladko1337lol
26.02.2020 12:36

var k1,k2,k3,k4,k:integer;

begin

writeln('Перед вами программа, которая умеет вычислять количество информации');

writeln('по выбранному наугад шарику из мешка.');

writeln('Введите число шаров белого цвета:');

readln(k1);

writeln('Введите число шаров чёрного цвета:');

readln(k2);

writeln('Введите число шаров синего цвета:');

readln(k3);

writeln('Введите число шаров красного цвета:');

readln(k4);

k:=k1+k2+k3+k4;

if k1<>0 then

writeln('Во фразе «Выпал белый шар» содержится ',log2(k/k1):4:1,' бит(а) информации');

if k2<>0 then

writeln('Во фразе «Выпал чёрный шар» содержится ',log2(k/k2):4:1,' бит(а) информации');

if k3<>0 then

writeln('Во фразе «Выпал синий шар» содержится ',log2(k/k3):4:1,' бит(а) информации');

if k4<>0 then

writeln('Во фразе «Выпал красный шар» содержится ',log2(k/k4):4:1,' бит(а) информации');

end.

Пример:

Перед вами программа, которая умеет вычислять количество информации

по выбранному наугад шарику из мешка.

Введите число шаров белого цвета:

100

Введите число шаров чёрного цвета:

0

Введите число шаров синего цвета:

200

Введите число шаров красного цвета:

100

Во фразе «Выпал белый шар» содержится  2.0 бит(а) информации

Во фразе «Выпал синий шар» содержится  1.0 бит(а) информации

Во фразе «Выпал красный шар» содержится  2.0 бит(а) информации

0,0(0 оценок)
Ответ:
yakupov72
26.02.2020 12:36

var k1,k2,k3,k4,k:integer;

begin

writeln('Перед вами программа, которая умеет вычислять количество информации');

writeln('по выбранному наугад шарику из мешка.');

writeln('Введите число шаров белого цвета:');

readln(k1);

writeln('Введите число шаров чёрного цвета:');

readln(k2);

writeln('Введите число шаров синего цвета:');

readln(k3);

writeln('Введите число шаров красного цвета:');

readln(k4);

k:=k1+k2+k3+k4;

if k1<>0 then

writeln('Во фразе «Выпал белый шар» содержится ',log2(k/k1):4:1,' бит(а) информации');

if k2<>0 then

writeln('Во фразе «Выпал чёрный шар» содержится ',log2(k/k2):4:1,' бит(а) информации');

if k3<>0 then

writeln('Во фразе «Выпал синий шар» содержится ',log2(k/k3):4:1,' бит(а) информации');

if k4<>0 then

writeln('Во фразе «Выпал красный шар» содержится ',log2(k/k4):4:1,' бит(а) информации');

end.

Пример:

Перед вами программа, которая умеет вычислять количество информации

по выбранному наугад шарику из мешка.

Введите число шаров белого цвета:

100

Введите число шаров чёрного цвета:

0

Введите число шаров синего цвета:

200

Введите число шаров красного цвета:

100

Во фразе «Выпал белый шар» содержится  2.0 бит(а) информации

Во фразе «Выпал синий шар» содержится  1.0 бит(а) информации

Во фразе «Выпал красный шар» содержится  2.0 бит(а) информации

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота