Terraria10299
10.02.2022 00:49

выполнить любое задание из 9
надо написать программу в паскале

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
andrewbukharin2
03.01.2021 22:54
Вот решение на C#
using System;
using System.Collections.Generic;
using System.Linq;

namespace Help


    class MainClass
    {
        public static void Main(string[] args)
        {
            int day = 1;
            double mass = 50;
            double changing = 1.2;
            
            while(mass < 120)
            {
                mass *= changing;
                day++;                
            }
            
            Console.WriteLine($"В {day} день");
        }
    }
}
0,0(0 оценок)
Ответ:
artemsavenkov
03.01.2021 22:54
PascalABC.NET 3.4.0, сборка 1672 от 10.06.2018
Внимание! Если программа не работает, обновите версию!

type
  tТовар=record
    Название:string[32];
    Цена:real;
    Количество:real; // может быть в килограммах или тоннах
    Поставщик:string[32]
    end;

begin
  var b:tТовар;
  var f:file of tТовар;
  // создаем (или чистим), а затем заполняем файл
  Rewrite(f,'Товары.typ');
  loop ReadlnInteger('Количество товаров:') do begin
    Writeln('Введите информацию по очередному товару');
    b.Название:=ReadlnString('Название:');
    (b.Цена,b.Количество):=ReadlnReal2('Цена товара и его количество:');
    b.Поставщик:=ReadlnString('Поставщик:');
    Write(f,b)
    end;
  f.Close;
  // работаем с файлом
  Reset(f);
  var nf:=Trim(ReadlnString('Какой поставщик интересует?'));
  while not eof(f) do begin
    Read(f,b);
    if Trim(b.Поставщик)=nf then
      Println(b.Название,b.Цена,b.Количество)
    end;
  f.Close
end.

Написать программу на языке программирования паскаль. сведения о товарах включают: название, цену, к
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота