malyovana2014
08.10.2022 03:39

(Python) Напишите программу, описывающую роботов-рабочих, на которых можно устанавливать различные инструменты.
- класс Tool - Инструмент. Каждый инструмент имеет запас прочности - 100 единиц, который уменьшается на 10 единиц, когда им работают.
Также у инструмента есть метод action(), который имитирует работу инструмента. По умолчанию он только уменьшает прочность инструмента при каждом вызове.
Напишите класс Robot.
По умолчанию у робота нет инструмента (в конструкторе нужно явно прописать это).
У робота должно быть три метода:
setup_tool() - установить инструмент - устанавливает указанный инструмент.
drop_tool() - снять инструмент - роняет текущий инструмент.
action() - выполнить действие. Метод должен вызвать action() того инструмента, который установлен на роботе. Если инструмент отсутствует или сломался, метод должен выводить соответствующие сообщения об ошибках.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
elena111104
27.01.2023 15:20

Чтение Задание 1. Прочитай текст. Английский плюс CD-ROM: блок 9 более высокий тест. Торговый центр Mall of America-это действительно большой торговый центр в США. Это больше, чем любой торговый центр в Европе! Расстояние до торгового центра составляет 390 000 метров?. Он имеет семь этажей и 52 Шора. Здесь четырнадцать кинотеатров и двадцать ресторанов, в торговом центре нет ни одной гостиницы, зато есть железнодорожный вокзал и автовокзал. В городе Миннеаполис есть несколько отелей. Город находится примерно в тридцати минутах езды от торгового центра. Меня зовут Бет, и моя семья живет в Миннеаполисе. Мы очень любим ходить по магазинам, и торговый центр-наше любимое место! Пишите правильно или неправильно: 1. Торговый центр Америки огромен 2. Торговый центр Америки находится в США 3. 3. На одном этаже расположены 52 магазина. 4. В торговом центре " 5 " есть места для фильмов. Бет не очень любит ходить по магазинам ответьте на этот во Насколько велик торговый центр Америки? 7. Сколько времени нужно, чтобы добраться от Миннеаполиса до торгового центра? письменные задания. Выберите одну из следующих тем. Йо вы должны: * высказать свое мнение по теме. Соедините свои идеи в один абзац. Используйте правильную форму модальных глаголов: нельзя, нужно, должно. Используйте пунктуацию соответствующим образом. Тема 1. Наш район какое место вы хотели бы посетить в своем соседстве? Почему тебе нравится это место? Какие достопримечательности вы хотели бы там увидеть? Вы бы хотели жить в этом месте? Почему? Тема 2. Транспорт какие виды транспорта вы знаете? Кто из них более опасен? Почему ты так думаешь? Разве это вредит жизни людей? Почему? Какой вид транспорта вы предпочитаете? Почему?

0,0(0 оценок)
Ответ:
altay2007
03.07.2022 17:28
Var n,m,osn: integer;
function nmbdec(var n,osn: integer): integer;
var nmb,l,s,k: integer;
begin
  nmb:=0;  s:=0;
  k:=n;  l:=1;
  while k>0 do
  begin
    s:=k mod 10;
    k:=k div 10;
    nmb:=nmb+l*s;
    l:=l*osn;
  end;
  Result:=nmb;
end;
{ конец функции}
begin
  write('число:  ');
  readln(n);
  write('квадрат какого числа:  ');
  readln(m);
  osn:=10;
  while osn>=2 do
  begin
     osn:=osn-1;
    if nmbdec(n,osn)=sqr(nmbdec(m,osn)) then
    begin
      writeln('основание системы = ',osn);
      break;
    end;
  end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота