irina83soft071
12.06.2022 13:35

На языке программирования Паскаль напишите программу для решения следующей задачи.
Три целых числа a, b и c, вводятся с клавиатуры. Составить программу, которая
удваивает каждое из данных чисел, если a

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
deemetraa
01.12.2020 22:33

картинка это 3 этап

1-й этап

Дано:

(40 − а) — количество проданных авиабилетов бизнес-класса по цене хрублей за билет;

(120 − b) — количество проданных авиабилетов экономического класса по цене х/2 рублей за билет.

Найти:

s — общую сумму, полученную компанией от продажи билетов за рейс.

2-й этап

Для нахождения s можно вычислить значение следующего выражения:

(40 − а) * х + (120 − b) * х/2.

Здесь а и b — целые величины, s — величина вещественного типа.

3-й этап

1-й этап

Дано:

(40 − а) — количество проданных авиабилетов бизнес-класса по цене хрублей за билет;

(120 − b) — количество проданных авиабилетов экономического класса по цене х/2 рублей за билет.

Найти:

s — общую сумму, полученную компанией от продажи билетов за рейс.

3-й этап

4-й этап

program n_13_63;

var a, b: integer; s, x: real;

begin

writeln (‘Подсчет суммы от продажи билетов’);

writeln (‘Количество а непроданных билетов бизнес-класса’);

readln (a);

writeln (‘Количество b непроданных билетов экономического класса’);

readln (b);

writeln (‘Стоимость билетов бизнес-класса х‘);

readln (x);

s:=(40−a)*x+(120−b)*x/2;

writeln (‘Билетов продано на ‘, s,’ руб.’)

end.

5-й этап

Протестировать программу можно по следующим данным:

а = 39,

b = 119,

х = 2000,

s = 3000.


УМОЛЯЮ НУЖНО ОЧЕНЬ В ИНФЕ ВООБЩЕ НЕ ШАРЮ ЕСЛИ НЕ СЛОЖНО, ТО С ОБЪЯСНЕНИЕМ. В аэробусе вмещающем 160
0,0(0 оценок)
Ответ:
SimpleNick
09.06.2023 20:48

10. Нам нужно удовлетворить условие

1000 < 4^x

Методом "великого тыка" берем x = 4.

4^4 = 256

256 < 1000

Не подходит. x + 1 = 5

4^5 = 1024

1024 > 1000 - Подходит

Следовательно, Ваше наименьшее k = 5

12. 00000- пустое множество

т.к. все нули, то множество будет пустым

01110- {3,5,7}

т.к. на 2,3,4 местах присутствует 1, то подмножество будет {3,5,7}

00111- {5,7,9}

т.к. на 3,4,5 местах присутствует 1, то подмножество будет {5,7,9}

11111- {1,3,5,7,9,}

т.к. везде присутствует 1, то подмножество будет {1,3,5,7,9}

у множества М может быть 32 различных подмножеств

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота