Арина1666
16.07.2021 09:38

Программы на Питоне, решающие следующие задачи

Задача 1

С клавиатуры получено четырехзначное число. Вывести на экран сообщение, содержащее ответ на во Верно ли, что все цифры данного числа четные?".

Задача 2

Напишите программу, которая получает с клавиатуры число роз (целое число, не превышающее 100) и выводит это число со словом «роза», «роз» или «розы». Например, «33 роза», «6 роз», «26 розы».

Задача 3

Пользователь с клавиатуры вводит два двузначных числа. Вывести на экран сообщение, содержащее ответ на во Верно ли, что сумма квадратов цифр первого числа равна сумме квадратов цифр второго числа?".

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Hеll
15.03.2022 00:57

#include <iostream>

#include <vector>

#include <cmath>

using namespace std;

struct river{

   string name;

   double length;

   double depth;

   bool ships;

};

signed main(){

   int n;

   cin >> n;

   river a[n];

   for(int i = 0; i < n; i++)

       cin >> a[i].name >> a[i].length >> a[i].depth >> a[i].ships;

   vector<river> ans;

   for(auto i: a)

       if(i.length > 2 && i.ships)

           ans.push_back(i);

   for(auto i: ans){

       cout << "name: " << i.name << "\n";

       cout << "length: " << i.length << "\n";

       cout << "depth: " << i.depth << "\n";

       cout << "ships?: Yes";

   }

}

0,0(0 оценок)
Ответ:
korobkovaangelina
15.03.2022 00:57

#include <iostream>

#include <vector>

#include <cmath>

using namespace std;

struct river{

   string name;

   double length;

   double depth;

   bool ships;

};

signed main(){

   int n;

   cin >> n;

   river a[n];

   for(int i = 0; i < n; i++)

       cin >> a[i].name >> a[i].length >> a[i].depth >> a[i].ships;

   vector<river> ans;

   for(auto i: a)

       if(i.length > 2 && i.ships)

           ans.push_back(i);

   for(auto i: ans){

       cout << "name: " << i.name << "\n";

       cout << "length: " << i.length << "\n";

       cout << "depth: " << i.depth << "\n";

       cout << "ships?: Yes";

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота