OМайгад
29.04.2023 17:42

2. Составьте программу рисования параллелограмма, две стороны которого параллельны
оси У и равны 9 единиц. Координаты двух его вершин (2; 0) и (4; 2).​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
bbll1998
20.04.2023 14:27

Введение:

Урок №12 курса "Практика" представляет разбор решения, наверное, самого популярного соревнования роботов - "Сумо". Главная задача робота-сумоиста состоит в том, чтобы вытолкнуть за пределы ринга своего соперника. Существует множество вариантов правил проведения этого состязания, накладывающих различные ограничения в первую очередь на размеры и конструкцию роботов, тем не менее, базовые алгоритмы поведения робота при этом очень похожи. Поэтому наш урок в значительной степени будет направлен на реализацию программы поведения, а в завершающей части урока рассмотрим некоторые советы по практической подготовке к соревнованию роботов.

12.1. Поле для проведения соревнования. Правила соревнования.  

Не смотря на то, что соревновательная дисциплина "Сумо" большинством организаторов соревнований позиционируется как состязание, предназначенное для начинающих робототехников, она пользуется неизменным вниманием не только участников, но и зрителей! Соревнования проводятся на двух видах полей: либо белый круг, ограниченный черной окружностью, либо, наоборот, черный круг, ограниченный белой окружностью. Очень часто макет поля наносится на круглый подиум небольшой высоты. В этом случае побежденный робот принуждается к падению (бывает, что с подиума падают оба участника битвы).

Для нашего урока мы возьмем то же самое поле, которое использовали при разборе Урока №11 - "Кегельринг". Это поле представляет собой белый круг, ограниченный черной окружностью. С классическими правилами проведения соревнования "Сумо" по версии Российской ассоциации образовательной робототехники вы можете ознакомиться под спойлером ниже:

Регламент соревнований роботов "Сумо" по версии сайта RAOR.RU  

12.2. Конструкция робота для соревнования "Сумо".  

Базовое поведение робота в "Сумо" очень похоже на поведение робота в "Кегельринге". Роботу также необходимо найти внутри поля объект и вытолкать его за пределы круга. Различия, как водится, кроятся в деталях: теперь этот объект в свою очередь ищет нашего робота и тоже жаждет вытолкать его поскорее.  

Соревнование "Сумо"

Тем не менее - сосредоточимся на своей цели: искать соперника нам по-прежнему будет один из датчиков определять предметы на расстоянии (инфракрасный или ультразвуковой), а своевременно определять черную границу поля будем с датчика цвета. Поэтому для создания и отладки программы робота-сумоиста предлагаем вам использовать того же самого робота, которого мы подготовили для Урока №11 - Кегельринг.  

Для того, чтобы защитить впереди расположенный датчик от взаимодействия с соперником, соорудим бампер и закрепим его на нашем роботе. Ниже приведены подробные инструкции для сборки, как из домашней, так и из образовательной версии конструктора Lego mindstorms EV3. Можете поэкспериментировать и придумать собственный вариант конструкции.

Lego mindstorms EV3 Home

Инструкция по сборке для домашней версии конструктора

Lego mindstorms EV3 Education

Инструкция по сборке для образовательной версии конструктора

Получившийся элемент закрепим на передней балке нашего робота.

Lego mindstorms EV3 Home

Размещение на домашней версии набора

Lego mindstorms EV3 Education

Размещение на образовательной версии набора

Наш учебный робот готов. Приступим к созданию программы робота-сумоиста. Замечательно, если у вас есть возможность отлаживать программу, используя ещё одного робота! Если же нет, то ничего страшного: можно задействовать в качестве соперника, например, радиоуправляемую модель автомобиля или те же кегли от "Кегельринга".  

0,0(0 оценок)
Ответ:
SHAHRUKH575
03.11.2021 07:48

Pascal:

 Var s, s1: real;

begin

 writeln('На какую сумму сделана покупка? ');

 readln(s);

 if s < 20000 then begin

   s1 := 0;

   writeln('К сожалению, мы не можем предоставить вам скидку')

   end

 else

   if s < 50000 then begin

     s1 := 0.1;

     writeln('Ваша скидка составит 10%');

     end

   else begin

     s1 := 0.2;

     writeln('Ваша скидка составляет 20%');

     end;

 writeln('Сумма к оплате ', s - s * s1);

! Приходите ещё.');

end.

Python:

print('Введите сумму покупки', end='')

s = float(input())

s1 = 0 if s<20000 else 0.1 if s<50000 else 0.2

if s1:

   print( 'Ваша скидка составляет ', s1*100,'%')

else:

   print( 'К сожалению, мы не можем сделать вам скидку')

print ('Сумма к оплате', s - s*s1)

. Приходите ещё')

Результаты выполнения:


Построить алгоритм и написать код программы к задаче: которая вычисляет сумму покупки со скидкой, ес
Построить алгоритм и написать код программы к задаче: которая вычисляет сумму покупки со скидкой, ес
Построить алгоритм и написать код программы к задаче: которая вычисляет сумму покупки со скидкой, ес
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота