123qwerty0
17.04.2021 14:21

Объясните : с клавиатуры вводится трёхзначное число. написать программу, которая составляет новое трёхзначное число, в котором цифры десятков и сотен поменяли местами. заранее большое !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mazaeva333
07.06.2020 22:53

Объяснение:

тут есть маленькая хитрость

Если записать число не как число а как строку то оно будет восприниматься как слово.

program bred;

var

x :string;

begin

writeln('Введите число': );

readln(x);           -    мы получаем число

writeln(x[2],x[1],x[3]); - указываем какую цифру мы берем и на какое место ставим

end.

Все! Удачи! Отметь этот ответ лучшим!

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота