катяkfrr
18.12.2021 00:25

Вариант 4.
№1. Напишите программу, которая в последовательности натуральных чисел
определяет сумму чисел, кратных 7.
Программа получает на вход количество чисел в последовательности, а
затем сами числа. В последовательности всегда имеется число, кратное 7.
Количество чисел не превышает 100. Введённые числа не превышает 300.
Программа должна вывести одно число — сумму чисел, кратных 7.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
qwerty836
12.08.2020 17:58

#include <iostream>

#include <cmath>

#include <algorithm>

#pragma GCC optimize("Ofast")

#define ll long long

#define ld long double

using namespace std;

signed main() {

  ll n;

  cin >> n;

  ll sum = 0;

  while(n--){

      ll x;

      cin >> x;

      if(x % 7 == 0)

          sum += x;

  }

  cout << sum;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота