Лилесим
17.12.2021 17:28

Напишите программу в паскале проверки устного счета - с сколько будет два плюс три,если клиент отвечает пять,высказываем одобрение,если не пять - выносим порицание​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Mihailevscaeanica
15.09.2021 19:26
1. Количество точек = 64*64.
Объем файла = 64*64*16 бит = 64*64*16/8 байт = 64*64*2 байт = 64*64*2/1024 Кбайт = 8 Кбайт

2. Размер цифрового моноаудиофайла измеряется по формуле:
     A = D*T*i,
где D – частота дискретизации (Гц), T – время звучания или записи звука, i - разрядность регистра (разрешение).
44,1 кГц = 44100 Гц
 A = 44100*2*16 бит = 44100*2*16 / (8*1024) Кбайт = 172,265625 Кбайт ≈ 172,3 Кбайт

3. Общее количество символов для записи номеров = 20+10=30
Для кодирования одного символа необходимо log(2)30 ≈ 5 бит (2^5=32).
Для записи одного номера требуется 8*5 бит = 40 бит = 40/8 байт = 5 байт
Для хранения 50 номеров потребуется 50*5 байт = 250 байт
0,0(0 оценок)
Ответ:
Islikzaziy
26.09.2020 22:18
Const
  n = 10;

var
  a: array[0..10] of integer;
  i, s: integer;

begin

//Заполнение массива сл. числами

  for i := 1 to n do
  begin
    a[i] := random(201) - 100;
    write(a[i]:4);
  end;
  writeln;

//1) Все элементы не превышающие число 100

  writeln('Не больше 100 ');
  for i := 1 to n do
    if a[i] <= 100 then
      write( a[i]:4);
  writeln;

// 2) Все четные элементы

  writeln('Кратные двум ');
  for i := 1 to n do
    if a[i] mod 2 = 0 then  
      write( a[i]:4);
  writeln;

// 3) Все элементы, являющиеся трехзначными числами

   writeln('Трехзначные ');
  for i := 1 to n do
    if (a[i] < -99) or (a[i] > 99) then  
      write(a[i]:4);
  writeln;

// 4) Третий, шестой и т.д элементы.

  i := 3;
  writeln(' номера 3, 6, 9 и  т.д.');
  while i < n do
  begin
    write(a[i]:4);
    i := i + 3;
  end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота