yMHNk1
13.06.2022 01:14

Написать программу на с++
Дана целочисленная квадратная матрица. Определить:

1) произведение элементов в тех строках, которые не содержат отрицательных элементов;

2) максимум среди сумм элементов диагоналей, параллельных главной диагонали матрицы.
не используя динамический массив

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Vanita111106
10.01.2021 19:22

просто перевод строк на паскаль. Логики тут искать не стоит. Первоначальное задание не полностью дано.

Объяснение:

const

 size = 6

var

 a : array [0..size, 0..size] of integer;

 d, v : array [0..size] of integer;

 i, temp, minindex, min, begin_index : integer;

begin

 begin_index := 0;

 for i:=0 to size-1 do begin

   temp := min + a[minindex][i]

   if temp < d[i] then

     d[i] := temp

 end;

 v[minindex] := 0;

 writeln('Кратчайшие расстояния до вершин')

 for i := 0 to size-1 do

   writeln(ver[i])  

end.

0,0(0 оценок)
Ответ:
artchapyshev
30.04.2020 02:29

840

Объяснение:

Функция рекурсивно вызывает саму себя с разными аргументами.

F(5) должна вычислить F(4) * 7

F(4) ----------------------------- F(3) * 6

F(3) ----------------------------- F(2) * 5

F(2) ----------------------------- F(1) * 4

F(1) возвращает 1.

F(2)  получает 1, вычисляет 1*4 и возвращает результат 4

F(3) получает 4, вычисляет 4*5 и возвращает 20

F(4) получает 20, вычисляет 20*6 и возвращает 120

F(5) получает 120, вычисляет 120*7 и возвращает 840

Основная программа получает 840 и выводит число на экран


Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота