Бота157
28.08.2021 13:47

1. Чему равно значение а после выполнения программы, если с=55 b=11 Var a,b,c: integer; Begin Read (с,b); If (с<>b) or (b mod 2=0) then а:=с*b else а:=с div 2; Writeln(a); End.
2. Напишите программу решения задачи. Дано четырехзначное число а. Если первая цифра этого числа больше последней, то вывести число а, увеличенное в 10 раз .
3. Напишите программу решения задачи. Дано число k. Если оно четное или не равно числу b, то вывести число k без изменения, иначе найти 1% от числа

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
янакуницкая2017
02.04.2020 01:00
Var x1,y1,x2,y2,v1,v2:real;
begin
  writeln("введите количество метров пробегания жирафа");
  read(y1);
  writeln("введите, за сколько секунд он должен пробежать");
  read(x1);
  writeln("введите количество метров пробегания зайца");
  read(y2);
  writeln("введите, за сколько секунд он должен пробежать");
  read(x2);
  v1:=y1/x1;
  v2:=y2/x2;
  if v1>v2 then 
  begin
     writeln("жираф чемпион");
  end
  else if v1<v2 then 
  begin
     writeln("заяц чемпион");
  end
  else
  begin
    writeln("победила дружба);
  end;
end;
0,0(0 оценок)
Ответ:
728099
07.01.2020 23:31

Для кодирования информации в компьютере вместо привычной десятичной системы счисления используется двоичная система счисления.

Двоичной системой счисления люди начали пользоваться очень давно. Древние племена Австралии и островов Полинезии использовали эту систему в быту. Так, полинезийцы передавали необходимую информацию, выполняя два вида ударов по барабану: звонкий и глухой. Это было примитивное представление двоичной системы счисления.

Двоичной системой счисления называется позиционная система счисления с основанием 2 .

Для записи чисел в ней использовали только две цифры: 0 и 1 .

Для обозначения системы счисления, в которой представляется число, используют нижний индекс, указывающий основание системы. Например, 110112 — число в двоичной системе счисления.

Цифры в двоичном числе являются коэффициентами его представления в виде суммы степеней с основанием 2 , например:

1012=1⋅22+0⋅21+1⋅20 .

В десятичной системе счисления это число будет выглядеть так:

1012=4+0+1=5 .

Для перевода целого десятичного числа в двоичную систему счисления нужно последовательно выполнять деление данного числа и получаемых целых частных на 2 до тех пор, пока не получим частное, равное нулю. Исходное число в двоичной системе счисления составляется последовательной записью полученных остатков, начиная с последнего.

Пример:

Переведём десятичное число 13 в двоичную систему счисления. Рассмотренную выше последовательность действий (алгоритм перевода) можно изобразить так:

13.png

Получили 1310=11012 .

Пример:

Если десятичное число достаточно большое, то более удобен следующий записи рассмотренного выше алгоритма:

224

112

56

28

14

7

3

1

0

0

0

0

0

1

1

1

22410=111000002 .

Восьмеричной системой счисления называется позиционная система счисления с основанием 8 .

Для записи чисел в восьмеричной системе счисления используются цифры: 0 , 1 , 2 , 3 , 4 , 5 , 6 , 7 .

Для перевода целого восьмеричного числа в десятичную систему счисления следует перейти к его развёрнутой записи и вычислить значение получившегося выражения.

Для перевода целого десятичного числа в восьмеричную систему счисления следует последовательно выполнять деление данного числа и получаемых целых частных на 8 до тех пор, пока не получим частное, равное нулю. Исходное число в восьмеричной системе счисления составляется последовательной записью полученных остатков, начиная с последнего.

Пример:

Переведём восьмеричное число 154368 в десятичную систему счисления.

154368=1⋅84+5⋅83+4⋅82+3⋅81+6⋅80=694210

Пример:

Переведём десятичное число 94 в восьмеричную систему счисления.

94.png

9410=1368

Шестнадцатеричной системой счисления называется позиционная система счисления с основанием 16 .

Для записи чисел в шестнадцатеричной системе счисления используются цифры: 0 , 1 , 2 , 3 , 4 , 5 , 6 , 7 , 8 , 9 и латинские буквы A, B, C, D, E, F. Буквы A, B, C, D, E, F имеют значения 1010 , 1110 , 1210 , 1310 , 1410 , 1510 .

Для перевода шестнадцатеричного числа в десятичное необходимо это число представить в виде суммы произведений степеней основания шестнадцатеричной системы счисления на соответствующие цифры в разрядах шестнадцатеричного числа.

Для перевода целого десятичного числа в шестнадцатеричную систему счисления следует последовательно выполнять деление данного числа и получаемых целых частных на 16 до тех пор, пока не получим частное, равное нулю. Исходное число в системе счисления составляется последовательной записью полученных остатков, начиная с последнего.

Пример:

Переведём шестнадцатеричное число 2 A7 в десятичное. В соответствии с вышеуказанными правилом представим его в виде суммы степеней с основанием 16 :

2A716=2⋅162+10⋅161+7⋅160=512+160+7=679 .

Пример:

Переведём десятичное число 158 в шестнадцатеричную систему счисления.

Безымянный111.png

15810=9E16 .

Для перевода числа из любой позиционной системы счисления в десятичную необходима использовать развернутую формулу числа, заменяя, если это необходимо, буквенные обозначения соответствующими цифрами.

Для перевода целых чисел десятичной системы счисления в число любой системы счисления последовательно выполняют деление нацело на основание системы счисления, пока не получат нуль. Числа, которые возникают как остаток от деления на основание системы счисление, представляют собой последовательную запись разрядов числа в выбранной системе счисления от младшего разряда к старшему. Поэтому для записи самого числа остатки от деления записывают в обратном порядке.

Предыдущая теория

Вернуться в тему

Следующее задание

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота