актан9ша
26.09.2021 23:05

Составить программу на паскале для решения задачи: Найти количество чисел,кратных 5 из промежутка от 21 до очень нужно

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
zhgulevatanya
21.09.2020 17:48
Const N = 5; M = 6;
var 
  a: array[1..N, 1..M] of integer;
  c: array[1..N] of integer;
  i, j, mx, mn: integer;
  
begin
  randomize;
  writeln('Исходная матрица');
  mn := 1;
  for i := 1 to N do begin
    mx := -(MaxInt-1);
    for j := 1 to M do begin
      // Случайное число от -500 до 500
      a[i, j] := Random(1001) - 500;
      // выводим
      write(a[i, j]:5, ' ');
      // Ищем макс в строке
      if mx < a[i,j] then mx := a[i,j];
    end;
    
    c[i] := mx; // макс в строке
    
    // Поиск минимума
    if c[mn] > c[i] then mn := i;
    writeln;
  end;
  
  writeln ('Вектор с');
  for i := 1 to N do 
    write(c[i]:5, ' ');
    
  writeln(#13, #10, 'минимальный элемент:');
  writeln('c[', mn, '] = ', c[mn]);
end.
0,0(0 оценок)
Ответ:
kurilkodanil
21.09.2020 17:48
#include <iostream>
#include <vector>

int main()
{
    int B[5][6];
    std::vector<int> Vec;
    for(int i = 0; i < 5; ++i)
        for(int j = 0; j < 6; ++j)
            std::cin >> B[i][j];
    for(int i = 0; i < 5; ++i)
    {
        int max = B[i][0];
        for(int j = 1; j < 6; ++j)
            if (max < B[i][j])
                max = B[i][j];
        Vec.push_back(max);
    }
    int min = Vec[0];
    int number = 0;
    for(int i = 1; i < 5; ++i) 
        if (min > Vec[i])
        {
            min = Vec[i];
            number = i;
        }
    std::cout << number;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота