ТКУиК9ks11
17.05.2020 18:57

составить программу. "Дано число (вводится пользователем с клавиатуры). Если число делится на 3 или оканчивается на 7, то вывести сообщение: Число удовлетворяет условию. В противном случае вывести сообщение: Заданное число не соответствует условию." язык - Паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vladkaz21004
10.08.2020 03:04
Var
  i:integer;
  s:string;
  f:Text;
begin
  Assign(f,'input.txt'); Reset(f);
  while not Eof(f) do begin
    Readln(f,s);
    Writeln(s,'   *** символов: ',Length(s))
  end;
  Close(f)
end.

Тестовое решение:
Буря мглою небо кроет,   *** символов: 22
Вихри снежные крутя;   *** символов: 20
То, как зверь, она завоет,   *** символов: 26
То заплачет, как дитя,   *** символов: 22
То по кровле обветшалой   *** символов: 23
Вдруг соломой зашумит,   *** символов: 22
То, как путник запоздалый,   *** символов: 26
К нам в окошко застучит   *** символов: 23
0,0(0 оценок)
Ответ:
natulina2009
28.02.2022 12:51

Задача по расчету объемов информации.

Итак 1.5 Кб передаются за 210 секунд.  Переведем 1.5 Кб в байты 1кб=1024 байт

1.5 умножим на 1024 = 1536 байт.

Рассчитаем пропускную канала связи.

Для этого разделим объем на время.

1536/210

теперь

Узнаем скорость передачи второго файла.

Объем 512 байт, будет передаваться 512/(1536/210)=70 секунд.


Можно пойти другим путем и увидеть, что 512 это ровно в три раза меньше чем 1.5 кб и тогда понятно что файл, который имеет в три раза меньший размер будет передаваться в три раза быстрее, значит 210/3=70 секунд



70 секунд. 512/(1,5*1024/210)=70

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота