terehovakira
02.10.2020 18:28

: написать программу для рисунка
начирти схему вправо закрасить в

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
1. Ручная прокрутка алгоритма

F₀ = 1; F₁ = 1;
F₂ = F₁×F₀+2 = 1×1+2=1+2 = 3;
F₃ = F₂×F₁+2 = 3×1+2 = 3+2 = 5;
F₄ = F₃×F₂+2 = 5×3+2 = 15+2 = 17;
F₅ = F₄×F₃+2 = 17×5+2 = 85+2 = 87

ответ: 87

2. Программное решение с использованием итерации

// PascalABC.NET 3.1, сборка 1204 от 24.03.2016
begin
  var f:array[0..5] of integer;
  f[0]:=1; f[1]:=1;
  for var i:=2 to 5 do f[i]:=f[i-1]*f[i-2]+2;
  Writeln(f[5])
end.

Результат выполнения программы
87

3. Программное решение с использованием рекурсии

// PascalABC.NET 3.1, сборка 1204 от 24.03.2016
function f(n:integer):integer;
begin
  if n<2 then Result:=1
  else Result:=f(n-1)*f(n-2)+2
end;

begin
  Writeln(f(5))
end.

Результат выполнения программы
87
0,0(0 оценок)
Ответ:
debchai123
08.09.2022 21:27
Хорошо, давай посмотрим на задачу пошагово.

Задачу можно разбить на следующие шаги:

Шаг 1: Получение двух трехзначных чисел
Первый шаг - получить два трехзначных числа. Давай предположим, что первое число называется "a" и второе число - "b".

Шаг 2: Вычисление сумм разрядов чисел
Теперь нужно вычислить суммы трех разрядов в каждом из заданных трехзначных чисел - старших, средних и младших разрядов.

Чтобы вычислить сумму старших разрядов числа "a", нужно сложить первую и вторую цифры числа "a". Давай обозначим эту сумму как "s1a". Аналогично, с помощью суммы "s1b" найдем сумму старших разрядов числа "b".

Затем вычислим сумму средних разрядов каждого числа. Для этого сложим вторую и третью цифры числа "a" и обозначим сумму как "s2a". Суммируем вторую и третью цифры числа "b" и обозначим их сумму как "s2b".

И, наконец, вычислим сумму младших разрядов, сложив третью цифру числа "a" с третьей цифрой числа "b". Обозначим эту сумму как "s3".

Таким образом, у нас есть три полученные суммы: s1a, s2a и s3 для числа "a" и s1b, s2b и s3 для числа "b".

Шаг 3: Запись полученных сумм в порядке неубывания
Теперь записываем полученные суммы друг за другом в порядке неубывания (от меньшего к большему), без разделителей.
То есть первым будет самое маленькое число из s1a, s2a и s3, затем следующее по величине, и, наконец, самое большое число. Обозначим это новое число как "result".

Шаг 4: Проверка ответа
Последний шаг - проверить правильность ответа.
Для этого приведем примеры из условия задачи:

- Пример а)
Исходные трехзначные числа: 857.
s1a = 8 + 5 = 13
s2a = 5 + 7 = 12
s3 = 7
Соответственно, новое число будет: 12137. Правильный ответ должен быть 81416.

- Пример б)
Исходные трехзначные числа: 714.
s1a = 7 + 1 = 8
s2a = 1 + 4 = 5
s3 = 4
Соответственно, новое число будет: 458. Правильный ответ должен быть 91012.

Давай проверим, что получено правильное новое число в обоих примерах. Видим, что ответы совпадают с заданными требованиями.

Таким образом, чтобы получить новое число, необходимо выполнить следующие шаги:
1) Получи два трехзначных числа "a" и "b";
2) Вычисли суммы старших, средних и младших разрядов для "a" и "b";
3) Запиши полученные суммы в порядке неубывания;
4) Проверь, совпадает ли полученное число с верным ответом.

Надеюсь, эта подробная инструкция поможет понять, как решать данную задачу. Если есть еще какие-либо вопросы, буду рад помочь!
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота