Vtscrntfigduufs
20.02.2021 08:05

5. Напишите программу вычесления выражений: ( )

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MigelAlemanValdes
30.08.2021 13:41
Program Project1;

var m:array [0..14] of integer; i:integer;

function IsPositive(a:integer):boolean;
begin
  result:=(a>-1);
end;

procedure work;
var min, max, count:integer;
begin
  count:=0;
  min:=m[0];
  max:=0;
  for i:=0 to 14 do begin
    if IsPositive(m[i]) then begin
      inc(count);
      if m[i]>max then max:=m[i];
      if m[i]<min then min:=m[i];
    end;
  end;
  writeln('MAX: ', max);
  writeln('MIN: ', min);
  writeln('Count: ', count);
end;

begin
  for i:=0 to 14 do begin
    write('n: ');
    readln(m[i]);
  end;

  work;

  readln;
end.
0,0(0 оценок)
Ответ:
AnnaNazar07
23.05.2023 01:56
Таких систем исчисления всего две.  Основание а = 9 и основание а =367, но в системе с основанием 367 проблематично записывать числа (символов не хватит).
Если число 3306(10) в системе исчисления с основанием а заканчивается цифрой 3, то тогда
число 3303 делится на основание системы а.
Отсюда алгоритм поиска.  Находим все делители числа 3303.
3303 = 3*1101 = 3*3*367.  Число 367 - простое. Поэтому основаниями системы исчисления 
могут быть только 3, 9, 367.  Основание =3 не подходит, так как по условию число должно заканчиваться на 3  -> основание больше 3.  Остаются 9, 367.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота